summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-11 19:54:42 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-11 19:54:42 +0000
commit298326f2af80766db42701b03dd322864cf15890 (patch)
tree7dfc9a79deae0566777973e21db0a3abb78128e6 /dev-ruby/right_http_connection
parentAdd patch from upstream to preserve From when copying mail from e.g. mbox to ... (diff)
downloadgentoo-2-298326f2af80766db42701b03dd322864cf15890.tar.gz
gentoo-2-298326f2af80766db42701b03dd322864cf15890.tar.bz2
gentoo-2-298326f2af80766db42701b03dd322864cf15890.zip
Add a patch that brings this on par with the http_connection-1.3.0 fork. Since the rest of the code in that gem is the same and it is a setback from this, don't even consider adding it until it improves.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/right_http_connection')
-rw-r--r--dev-ruby/right_http_connection/ChangeLog11
-rw-r--r--dev-ruby/right_http_connection/files/right_http_connection-1.2.4+ruby-1.9.patch10
-rw-r--r--dev-ruby/right_http_connection/right_http_connection-1.2.4-r1.ebuild31
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/right_http_connection/ChangeLog b/dev-ruby/right_http_connection/ChangeLog
index 3b89e2947f22..ef6bf49ffa8f 100644
--- a/dev-ruby/right_http_connection/ChangeLog
+++ b/dev-ruby/right_http_connection/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-ruby/right_http_connection
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_http_connection/ChangeLog,v 1.1 2010/01/12 14:07:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_http_connection/ChangeLog,v 1.2 2010/02/11 19:54:42 flameeyes Exp $
+
+*right_http_connection-1.2.4-r1 (11 Feb 2010)
+
+ 11 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +right_http_connection-1.2.4-r1.ebuild,
+ +files/right_http_connection-1.2.4+ruby-1.9.patch:
+ Add a patch that brings this on par with the http_connection-1.3.0 fork.
+ Since the rest of the code in that gem is the same and it is a setback
+ from this, don't even consider adding it until it improves.
*right_http_connection-1.2.4 (12 Jan 2010)
diff --git a/dev-ruby/right_http_connection/files/right_http_connection-1.2.4+ruby-1.9.patch b/dev-ruby/right_http_connection/files/right_http_connection-1.2.4+ruby-1.9.patch
new file mode 100644
index 000000000000..3133194fefb7
--- /dev/null
+++ b/dev-ruby/right_http_connection/files/right_http_connection-1.2.4+ruby-1.9.patch
@@ -0,0 +1,10 @@
+--- lib/right_http_connection.rb.old 2010-01-28 00:35:07.000000000 +0100
++++ lib/right_http_connection.rb 2010-02-11 20:20:28.872034048 +0100
+@@ -299,6 +299,7 @@
+ true
+ }
+ @http.use_ssl = true
++ @http.verify_mode = OpenSSL::SSL::VERIFY_NONE # Looks like Ruby 1.9 defaults to VERIFY_PEER which doesn't work well
+ ca_file = get_param(:ca_file)
+ if ca_file
+ @http.verify_mode = OpenSSL::SSL::VERIFY_PEER
diff --git a/dev-ruby/right_http_connection/right_http_connection-1.2.4-r1.ebuild b/dev-ruby/right_http_connection/right_http_connection-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..f7f100ff9dfe
--- /dev/null
+++ b/dev-ruby/right_http_connection/right_http_connection-1.2.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_http_connection/right_http_connection-1.2.4-r1.ebuild,v 1.1 2010/02/11 19:54:42 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="RightScale's robust HTTP/S connection module"
+HOMEPAGE="http://rightscale.rubyforge.org/"
+
+LICENSE="as-is" # truly
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ # This patch is taken from the http_connection fork
+ # http://github.com/appoxy/http_connection
+ # It's the only change in the 1.3.0 release, which is otherwise
+ # quite a setback in term of gems.
+ epatch "${FILESDIR}"/${P}+ruby-1.9.patch
+}