summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Kohl <citizen428@gentoo.org>2005-01-26 16:32:31 +0000
committerMichael Kohl <citizen428@gentoo.org>2005-01-26 16:32:31 +0000
commit41eabb394b046825670fbdb95f1b21fe08f1110e (patch)
treeed96201aa18dacc2acf6a872a6be8ed19760716c /dev-ruby/redcloth
parentMoved dopamd to eutils.eclass. (diff)
downloadgentoo-2-41eabb394b046825670fbdb95f1b21fe08f1110e.tar.gz
gentoo-2-41eabb394b046825670fbdb95f1b21fe08f1110e.tar.bz2
gentoo-2-41eabb394b046825670fbdb95f1b21fe08f1110e.zip
Initial import. Ebuild submitted by Leonardo Boshell in bug #71520
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-ruby/redcloth')
-rw-r--r--dev-ruby/redcloth/ChangeLog10
-rw-r--r--dev-ruby/redcloth/Manifest3
-rw-r--r--dev-ruby/redcloth/files/digest-redcloth-3.0.11
-rw-r--r--dev-ruby/redcloth/metadata.xml9
-rw-r--r--dev-ruby/redcloth/redcloth-3.0.1.ebuild32
5 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/redcloth/ChangeLog b/dev-ruby/redcloth/ChangeLog
new file mode 100644
index 000000000000..f8d91c233bf7
--- /dev/null
+++ b/dev-ruby/redcloth/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/redcloth
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.1 2005/01/26 16:32:31 citizen428 Exp $
+
+*redcloth-3.0.1 (26 Jan 2005)
+
+ 26 Jan 2005; Michael Kohl <citizen428@gentoo.org> +metadata.xml,
+ +redcloth-3.0.1.ebuild:
+ Initial import. Ebuild submitted by Leonardo Boshell in bug #71520
+
diff --git a/dev-ruby/redcloth/Manifest b/dev-ruby/redcloth/Manifest
new file mode 100644
index 000000000000..639f05eeb6a1
--- /dev/null
+++ b/dev-ruby/redcloth/Manifest
@@ -0,0 +1,3 @@
+MD5 0167a741b627cb067b483f533c37e1ec redcloth-3.0.1.ebuild 809
+MD5 1a24e0b48460c02e20931fceded24e1a metadata.xml 254
+MD5 21377cbdd036ae765522479d45792805 files/digest-redcloth-3.0.1 65
diff --git a/dev-ruby/redcloth/files/digest-redcloth-3.0.1 b/dev-ruby/redcloth/files/digest-redcloth-3.0.1
new file mode 100644
index 000000000000..ecbac2c1949c
--- /dev/null
+++ b/dev-ruby/redcloth/files/digest-redcloth-3.0.1
@@ -0,0 +1 @@
+MD5 af2cd744f20baf3ae2c8eeacf506b614 RedCloth-3.0.1.tar.gz 35698
diff --git a/dev-ruby/redcloth/metadata.xml b/dev-ruby/redcloth/metadata.xml
new file mode 100644
index 000000000000..7e86655fcda4
--- /dev/null
+++ b/dev-ruby/redcloth/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <maintainer>
+ <email>citizen428@gentoo.org</email>
+ <name>Michael Kohl</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/redcloth/redcloth-3.0.1.ebuild b/dev-ruby/redcloth/redcloth-3.0.1.ebuild
new file mode 100644
index 000000000000..7ad4697cfe8b
--- /dev/null
+++ b/dev-ruby/redcloth/redcloth-3.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-3.0.1.ebuild,v 1.1 2005/01/26 16:32:31 citizen428 Exp $
+
+inherit ruby
+
+MY_P="RedCloth-${PV}"
+
+DESCRIPTION="A module for using Textile in Ruby"
+HOMEPAGE="http://www.whytheluckystiff.net/ruby/redcloth/"
+SRC_URI="http://rubyforge.org/frs/download.php/2679/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+USE_RUBY="any"
+DEPEND="virtual/ruby"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ ruby install.rb config --prefix=/usr || die "ruby install.rb config failed"
+ ruby install.rb setup || die "ruby install.rb setup failed"
+}
+
+src_install() {
+ ruby install.rb config --prefix=${D}/usr || die "ruby install.rb config failed"
+ ruby install.rb install || die "ruby install.rb install failed"
+ dodoc doc/CHANGELOG doc/README doc/REFERENCE
+}