summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-08-18 00:45:24 +0000
committerAron Griffis <agriffis@gentoo.org>2002-08-18 00:45:24 +0000
commite5a2726c4652c258c43cd2a1010c5dc8944fe094 (patch)
treee749fdec40d94a200f018435205701ff0b7c7873 /dev-ruby/rdtool
parentupdated to racc-1.4.1 (diff)
downloadgentoo-2-e5a2726c4652c258c43cd2a1010c5dc8944fe094.tar.gz
gentoo-2-e5a2726c4652c258c43cd2a1010c5dc8944fe094.tar.bz2
gentoo-2-e5a2726c4652c258c43cd2a1010c5dc8944fe094.zip
updated to rdtool-0.6.11
Diffstat (limited to 'dev-ruby/rdtool')
-rw-r--r--dev-ruby/rdtool/ChangeLog27
-rw-r--r--dev-ruby/rdtool/files/digest-rdtool-0.6.111
-rw-r--r--dev-ruby/rdtool/rdtool-0.6.11.ebuild30
3 files changed, 48 insertions, 10 deletions
diff --git a/dev-ruby/rdtool/ChangeLog b/dev-ruby/rdtool/ChangeLog
index f62b42e4c7fc..df5e60dc0c6f 100644
--- a/dev-ruby/rdtool/ChangeLog
+++ b/dev-ruby/rdtool/ChangeLog
@@ -1,17 +1,24 @@
# ChangeLog for dev-ruby/rdtool
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdtool/ChangeLog,v 1.2 2002/07/08 02:55:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdtool/ChangeLog,v 1.3 2002/08/18 00:45:24 agriffis Exp $
+
+*rdtool-0.6.11 (17 Aug 2002)
+
+ 17 Aug 2002; Aron Griffis <agriffis@gentoo.org> rdtool-0.6.11.ebuild:
+
+ Updated to version 0.6.11 which depends on newer racc as well.
*rdtool-0.6.6 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
- 07 Jul 2002; Aron Griffis <agriffis@gentoo.org> rdtool-0.6.6.ebuild:
+ 07 Jul 2002; Aron Griffis <agriffis@gentoo.org> rdtool-0.6.6.ebuild:
- Added LICENSE, KEYWORDS, SLOT.
+ Added LICENSE, KEYWORDS, SLOT.
diff --git a/dev-ruby/rdtool/files/digest-rdtool-0.6.11 b/dev-ruby/rdtool/files/digest-rdtool-0.6.11
new file mode 100644
index 000000000000..ff5b79c2f234
--- /dev/null
+++ b/dev-ruby/rdtool/files/digest-rdtool-0.6.11
@@ -0,0 +1 @@
+MD5 862d16ad0bfad9de2d59fa3ef3728e23 rdtool-0.6.11.tar.gz 50097
diff --git a/dev-ruby/rdtool/rdtool-0.6.11.ebuild b/dev-ruby/rdtool/rdtool-0.6.11.ebuild
new file mode 100644
index 000000000000..f5028f3a2f36
--- /dev/null
+++ b/dev-ruby/rdtool/rdtool-0.6.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdtool/rdtool-0.6.11.ebuild,v 1.1 2002/08/18 00:45:24 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Fast string scanning library for Ruby"
+SRC_URI="http://www2.pos.to/~tosh/ruby/rdtool/archive/${P}.tar.gz"
+HOMEPAGE="http://www2.pos.to/~tosh/ruby/rdtool/en/index.html"
+LICENSE="Ruby"
+KEYWORDS="x86"
+SLOT="0"
+
+DEPEND=">=dev-lang/ruby-1.6.1
+ >=dev-ruby/racc-1.3
+ >=dev-ruby/strscan-0.5.8
+ >=dev-ruby/optparse-0.7.5"
+
+src_compile() {
+ ruby rdtoolconf.rb || die
+ make || die
+}
+
+src_install () {
+ chmod 755 rd2
+ dobin rd2
+
+ cd ${S}/rd
+ insinto /usr/lib/ruby/site_ruby/1.6/rd
+ doins dot.rd2rc *.rb
+}