summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-25 15:24:23 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-25 15:24:23 +0000
commitad1e13eb1e49c1f243b88fdf9370c858d0bd328e (patch)
tree77e9465f3469f31beda3c43a1fc167d58b76159c /dev-ruby/rcov
parentInitial commit wrt #294919, thanks to David Raison for reporting. (diff)
downloadgentoo-2-ad1e13eb1e49c1f243b88fdf9370c858d0bd328e.tar.gz
gentoo-2-ad1e13eb1e49c1f243b88fdf9370c858d0bd328e.tar.bz2
gentoo-2-ad1e13eb1e49c1f243b88fdf9370c858d0bd328e.zip
Bump to ruby-fakegem, add support for ruby19 and jruby.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rcov')
-rw-r--r--dev-ruby/rcov/ChangeLog8
-rw-r--r--dev-ruby/rcov/rcov-0.9.6-r1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/rcov/ChangeLog b/dev-ruby/rcov/ChangeLog
index 664b0368a7e9..620012e45e4d 100644
--- a/dev-ruby/rcov/ChangeLog
+++ b/dev-ruby/rcov/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rcov
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.8 2009/12/05 08:32:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.9 2009/12/25 15:24:23 flameeyes Exp $
+
+*rcov-0.9.6-r1 (25 Dec 2009)
+
+ 25 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +rcov-0.9.6-r1.ebuild:
+ Bump to ruby-fakegem, add support for ruby19 and jruby.
*rcov-0.9.6 (05 Dec 2009)
diff --git a/dev-ruby/rcov/rcov-0.9.6-r1.ebuild b/dev-ruby/rcov/rcov-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..e01b0f73428c
--- /dev/null
+++ b/dev-ruby/rcov/rcov-0.9.6-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/rcov-0.9.6-r1.ebuild,v 1.1 2009/12/25 15:24:23 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="THANKS BLURB"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby code coverage analysis tool"
+HOMEPAGE="http://eigenclass.org/hiki.rb?rcov"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# TODO: both emacs and vim support are present in this package, they
+# should probably be added to the ebuild as well.
+IUSE=""
+
+# tests fail because the gem does not package the needed files, and
+# there is no tag in github to fetch a tarball.
+# http://github.com/relevance/rcov/issues/#issue/36
+RESTRICT=test
+
+each_ruby_compile() {
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ${RUBY} -S rake ext/rcovrt/rcovrt.so || die "build failed"
+ fi
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ruby_fakegem_newins ext/rcovrt/rcovrt.so lib/rcovrt.so
+ fi
+}