summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-29 05:09:12 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-29 05:09:12 +0000
commit2248b7c6731d1aed956e09ec772cb09144b51f01 (patch)
treeb7eb109824f864f79404d97d0e0215a06586c8d2 /dev-ruby/rcov
parentConvert to ruby-fakegem. (diff)
downloadgentoo-2-2248b7c6731d1aed956e09ec772cb09144b51f01.tar.gz
gentoo-2-2248b7c6731d1aed956e09ec772cb09144b51f01.tar.bz2
gentoo-2-2248b7c6731d1aed956e09ec772cb09144b51f01.zip
Version bump. Upstream did not tag release, using hash instead. Tests still fail.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rcov')
-rw-r--r--dev-ruby/rcov/ChangeLog8
-rw-r--r--dev-ruby/rcov/rcov-0.9.8.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-ruby/rcov/ChangeLog b/dev-ruby/rcov/ChangeLog
index 3ddd4c961a2d..058b79971e10 100644
--- a/dev-ruby/rcov/ChangeLog
+++ b/dev-ruby/rcov/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rcov
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.16 2010/05/01 00:47:04 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.17 2010/06/29 05:09:12 graaff Exp $
+
+*rcov-0.9.8 (29 Jun 2010)
+
+ 29 Jun 2010; Hans de Graaff <graaff@gentoo.org> +rcov-0.9.8.ebuild:
+ Version bump. Upstream did not tag release, using hash instead. Tests
+ still fail.
01 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> rcov-0.9.7.1.ebuild:
Restore original SRC_URI.
diff --git a/dev-ruby/rcov/rcov-0.9.8.ebuild b/dev-ruby/rcov/rcov-0.9.8.ebuild
new file mode 100644
index 000000000000..d7a4ad4daac3
--- /dev/null
+++ b/dev-ruby/rcov/rcov-0.9.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/rcov-0.9.8.ebuild,v 1.1 2010/06/29 05:09:12 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="test_rcovrt"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="THANKS BLURB"
+
+inherit ruby-fakegem versionator eutils
+
+DESCRIPTION="A ruby code coverage analysis tool"
+HOMEPAGE="http://eigenclass.org/hiki.rb?rcov"
+#SRC_URI="http://github.com/relevance/${PN}/tarball/release_$(replace_all_version_separators _) -> ${P}.tgz"
+SRC_URI="http://github.com/relevance/${PN}/tarball/4d94640ac1ff79c272c78307437ecccc93fedabe -> ${P}.tgz"
+
+S="${WORKDIR}/relevance-${PN}-*"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# TODO: both emacs and vim support are present in this package, they
+# should probably be added to the ebuild as well.
+IUSE=""
+
+# Tests are currently failing but upstream says it should be fine, I
+# think it's a bug in their code but we'll see.
+RESTRICT=test
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9.7.1-jruby.patch
+
+ # Without this change, testing will always cause the extension to
+ # be rebuilt, and we don't want that.
+ sed -i -e '/:test_rcovrt =>/s| => \[.*\]||' Rakefile || die "Rakefile fix failed"
+
+ # remove pre-packaged jar file (d'oh!)
+ rm lib/rcovrt.jar || die
+}
+
+each_ruby_compile() {
+ if [[ $(basename ${RUBY}) = "jruby" ]]; then
+ ${RUBY} -S rake lib/rcovrt.jar || die "build failed"
+ else
+ ${RUBY} -S rake ext/rcovrt/rcovrt.so || die "build failed"
+ fi
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ruby_fakegem_newins ext/rcovrt/rcovrt.so lib/rcovrt.so
+ fi
+}