summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-01-07 07:08:01 +0000
committerHans de Graaff <graaff@gentoo.org>2014-01-07 07:08:01 +0000
commitf8599017874f877d4e667a975ca8af37a6ab07e4 (patch)
tree20b18d727673768594d5f0d383d52362d66a038e /dev-ruby/rcairo/rcairo-1.12.8.ebuild
parentx11-libs/qwt: Readd old version to fix broken deps, #497326 (diff)
downloadgentoo-2-f8599017874f877d4e667a975ca8af37a6ab07e4.tar.gz
gentoo-2-f8599017874f877d4e667a975ca8af37a6ab07e4.tar.bz2
gentoo-2-f8599017874f877d4e667a975ca8af37a6ab07e4.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rcairo/rcairo-1.12.8.ebuild')
-rw-r--r--dev-ruby/rcairo/rcairo-1.12.8.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-ruby/rcairo/rcairo-1.12.8.ebuild b/dev-ruby/rcairo/rcairo-1.12.8.ebuild
new file mode 100644
index 000000000000..d69861880ca5
--- /dev/null
+++ b/dev-ruby/rcairo/rcairo-1.12.8.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/rcairo-1.12.8.ebuild,v 1.1 2014/01/07 07:08:01 graaff Exp $
+
+EAPI=5
+
+# jruby → cannot work, it's a compiled extension
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_NAME="cairo"
+
+# Documentation depends on files that are not distributed.
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="AUTHORS NEWS"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby bindings for cairo"
+HOMEPAGE="http://cairographics.org/rcairo/"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="|| ( Ruby GPL-2 )"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="${RDEPEND}
+ >=x11-libs/cairo-1.2.0[svg]"
+DEPEND="${DEPEND}
+ >=x11-libs/cairo-1.2.0[svg]"
+
+ruby_add_bdepend "
+ dev-ruby/pkg-config
+ dev-ruby/ruby-glib2
+ test? ( >=dev-ruby/test-unit-2.1.0-r1:2 )"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/cairo extconf.rb || die "extconf failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/cairo || die "make failed"
+
+ # again, try to make it more standard, to install it more easily.
+ cp ext/cairo/cairo$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ # don't rely on the Rakefile because it's a mess to load with
+ # their hierarchy, do it manually.
+ ${RUBY} -Ilib -r ./test/cairo-test-utils.rb \
+ -e 'gem "test-unit"; require "test/unit"; Dir.glob("test/**/test_*.rb") {|f| load f}' || die "tests failed"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ insinto $(ruby_get_hdrdir)
+ doins ext/cairo/rb_cairo.h || die "Cannot install header file."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/samples
+ doins -r samples/* || die "Cannot install sample files."
+}