summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-13 23:53:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-13 23:53:35 +0000
commit0bce32f8f584bd82e31e0dd1238374633ccc3513 (patch)
tree11ce374c504cb5bcc93a363d51a0654be74d3be6 /dev-ruby/rash
parentStable ppc, bug #422227 (diff)
downloadgentoo-2-0bce32f8f584bd82e31e0dd1238374633ccc3513.tar.gz
gentoo-2-0bce32f8f584bd82e31e0dd1238374633ccc3513.tar.bz2
gentoo-2-0bce32f8f584bd82e31e0dd1238374633ccc3513.zip
Use the rspec recipe for testing; add Ruby 1.9 support.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rash')
-rw-r--r--dev-ruby/rash/ChangeLog8
-rw-r--r--dev-ruby/rash/rash-0.3.2.ebuild9
2 files changed, 9 insertions, 8 deletions
diff --git a/dev-ruby/rash/ChangeLog b/dev-ruby/rash/ChangeLog
index e50fc72d47f8..860a9439a111 100644
--- a/dev-ruby/rash/ChangeLog
+++ b/dev-ruby/rash/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/rash
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rash/ChangeLog,v 1.2 2011/12/24 13:26:05 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rash/ChangeLog,v 1.3 2012/08/13 23:53:35 flameeyes Exp $
+
+ 13 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> rash-0.3.2.ebuild:
+ Use the rspec recipe for testing; add Ruby 1.9 support.
*rash-0.3.2 (24 Dec 2011)
@@ -12,4 +15,3 @@
23 Aug 2011; Hans de Graaff <graaff@gentoo.org> +rash-0.3.0.ebuild,
+metadata.xml:
Initial import. Dependency of forthcoming faraday_middleware.
-
diff --git a/dev-ruby/rash/rash-0.3.2.ebuild b/dev-ruby/rash/rash-0.3.2.ebuild
index 678e98e3d2e3..1e7d5a19e0c2 100644
--- a/dev-ruby/rash/rash-0.3.2.ebuild
+++ b/dev-ruby/rash/rash-0.3.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rash/rash-0.3.2.ebuild,v 1.1 2011/12/24 13:26:05 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rash/rash-0.3.2.ebuild,v 1.2 2012/08/13 23:53:35 flameeyes Exp $
EAPI=4
-USE_RUBY="ruby18 ree18 jruby"
+USE_RUBY="ruby18 ruby19 ree18 jruby"
-RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_EXTRADOC="README.rdoc"
@@ -20,7 +20,6 @@ KEYWORDS="~amd64"
IUSE=""
ruby_add_rdepend ">=dev-ruby/hashie-1.2.0"
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 )"
all_ruby_prepare() {
rm Gemfile || die