summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-05-25 05:05:05 +0000
committerHans de Graaff <graaff@gentoo.org>2015-05-25 05:05:05 +0000
commit3dccf78de4a3b9cd6ba34a112c824ed2ae6cfdc4 (patch)
tree2e604d8956a5e84006316ba606e7a4be944883a2 /dev-ruby/rash/rash-0.4.0-r2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-3dccf78de4a3b9cd6ba34a112c824ed2ae6cfdc4.tar.gz
gentoo-2-3dccf78de4a3b9cd6ba34a112c824ed2ae6cfdc4.tar.bz2
gentoo-2-3dccf78de4a3b9cd6ba34a112c824ed2ae6cfdc4.zip
Make hashie dependency more lenient to match versions still in the tree.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rash/rash-0.4.0-r2.ebuild')
-rw-r--r--dev-ruby/rash/rash-0.4.0-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rash/rash-0.4.0-r2.ebuild b/dev-ruby/rash/rash-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..9e389c26b35a
--- /dev/null
+++ b/dev-ruby/rash/rash-0.4.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rash/rash-0.4.0-r2.ebuild,v 1.1 2015/05/25 05:05:05 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rash is an extension to Hashie"
+HOMEPAGE="https://github.com/tcocca/rash"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/hashie-2.0.0:0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ sed -i -e '/hashie/ s/2.0.0/2.0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}