summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-08-05 04:43:29 +0000
committerHans de Graaff <graaff@gentoo.org>2014-08-05 04:43:29 +0000
commit8c58f8e1006ff4bc5e7a7a2dc9a588248300f551 (patch)
tree2f483bbb961891cb56d521e7611a1db40a1a4d8a /dev-ruby/rake-compiler
parentadd py2.7 support, fixes Bug #518966 (diff)
downloadgentoo-2-8c58f8e1006ff4bc5e7a7a2dc9a588248300f551.tar.gz
gentoo-2-8c58f8e1006ff4bc5e7a7a2dc9a588248300f551.tar.bz2
gentoo-2-8c58f8e1006ff4bc5e7a7a2dc9a588248300f551.zip
Version bump. Enable specs and feature tests for more ruby targets. Drop sparc keyword as a consequence of it, bug 465948.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rake-compiler')
-rw-r--r--dev-ruby/rake-compiler/ChangeLog8
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.9.3.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-ruby/rake-compiler/ChangeLog b/dev-ruby/rake-compiler/ChangeLog
index c88467f08ecc..e8a5a5b940cf 100644
--- a/dev-ruby/rake-compiler/ChangeLog
+++ b/dev-ruby/rake-compiler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rake-compiler
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.81 2014/07/25 12:42:00 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.82 2014/08/05 04:43:29 graaff Exp $
+
+*rake-compiler-0.9.3 (05 Aug 2014)
+
+ 05 Aug 2014; Hans de Graaff <graaff@gentoo.org> +rake-compiler-0.9.3.ebuild:
+ Version bump. Enable specs and feature tests for more ruby targets. Drop
+ sparc keyword as a consequence of it, bug 465948.
25 Jul 2014; Manuel Rüger <mrueg@gentoo.org> -rake-compiler-0.8.3.ebuild:
Cleanup old.
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.9.3.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.9.3.ebuild
new file mode 100644
index 000000000000..964b77694993
--- /dev/null
+++ b/dev-ruby/rake-compiler/rake-compiler-0.9.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/rake-compiler-0.9.3.ebuild,v 1.1 2014/08/05 04:43:29 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
+HOMEPAGE="http://github.com/luislavena/rake-compiler"
+LICENSE="MIT"
+
+SRC_URI="http://github.com/luislavena/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rake"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+USE_RUBY="ruby19 ruby20" ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19|*jruby)
+ # Remove this task so that it won't load on Ruby 1.9 and JRuby
+ # that lack the package_task file. It is, though, needed for the
+ # tests
+ rm tasks/gem.rake || die
+ # Remove specs aimed at a C-compiling ruby implementation.
+ rm spec/lib/rake/extensiontask_spec.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ # Skip cucumber for jruby (not supported) and ruby20 (not ready yet)
+ case ${RUBY} in
+ *ruby19|*ruby20)
+ ruby-ng_rspec
+ ruby-ng_cucumber
+ ;;
+ *)
+ ruby-ng_rspec
+ ;;
+ esac
+}