summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-30 19:48:41 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-30 19:48:41 +0000
commitcffed6117c84166aa160c82c0f8ed4fa13a875f9 (patch)
tree21ff62a70342dbd142748a3eed5f76e6316b433b /dev-ruby/railties
parentVersion bump. Add ruby19. Drop arches due to bug 396547. (diff)
downloadgentoo-2-cffed6117c84166aa160c82c0f8ed4fa13a875f9.tar.gz
gentoo-2-cffed6117c84166aa160c82c0f8ed4fa13a875f9.tar.bz2
gentoo-2-cffed6117c84166aa160c82c0f8ed4fa13a875f9.zip
Version bump. Add ruby19. Drop arches due to bug 396547.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/railties')
-rw-r--r--dev-ruby/railties/ChangeLog7
-rw-r--r--dev-ruby/railties/railties-3.1.3.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-ruby/railties/ChangeLog b/dev-ruby/railties/ChangeLog
index 0bd8c8a965b0..6d164a21008d 100644
--- a/dev-ruby/railties/ChangeLog
+++ b/dev-ruby/railties/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/railties
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/ChangeLog,v 1.16 2011/11/19 11:07:18 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/ChangeLog,v 1.17 2011/12/30 19:48:41 graaff Exp $
+
+*railties-3.1.3 (30 Dec 2011)
+
+ 30 Dec 2011; Hans de Graaff <graaff@gentoo.org> +railties-3.1.3.ebuild:
+ Version bump. Add ruby19. Drop arches due to bug 396547.
*railties-3.0.11 (19 Nov 2011)
diff --git a/dev-ruby/railties/railties-3.1.3.ebuild b/dev-ruby/railties/railties-3.1.3.ebuild
new file mode 100644
index 000000000000..10fc2c18db4b
--- /dev/null
+++ b/dev-ruby/railties/railties-3.1.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/railties-3.1.3.ebuild,v 1.1 2011/12/30 19:48:41 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="test:regular"
+RUBY_FAKEGEM_TASK_DOC="generate_guides"
+RUBY_FAKEGEM_DOCDIR="guides/output"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="railties.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools for creating, working with, and running Rails applications."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="rails-rails-*/railties"
+
+# The test suite has many failures, most likely due to a mismatch in
+# exact dependencies or environment specifics. Needs further
+# investigation.
+RESTRICT="test"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/rdoc-3.4
+ >=dev-ruby/thor-0.14.6
+ >=dev-ruby/rack-ssl-1.3.2:1.3
+ >=dev-ruby/rake-0.8.7"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )
+ doc? (
+ >=dev-ruby/redcloth-4.1.1
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\)/d' ../Gemfile || die
+}