summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-07-28 08:20:24 +0000
committerHans de Graaff <graaff@gentoo.org>2012-07-28 08:20:24 +0000
commitd21dfa1d462b6eb40a0a926cb5aac9851d9ef95b (patch)
tree99bdfb57e4f684199721cfff84d668e686c71c36 /dev-ruby/rails
parentVersion bump for Rails 3.0.16, bug 428254. (diff)
downloadgentoo-2-d21dfa1d462b6eb40a0a926cb5aac9851d9ef95b.tar.gz
gentoo-2-d21dfa1d462b6eb40a0a926cb5aac9851d9ef95b.tar.bz2
gentoo-2-d21dfa1d462b6eb40a0a926cb5aac9851d9ef95b.zip
Version bump for Rails 3.0.16, bug 428254.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-3.0.16.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index ab5ea2a1e710..a104e55d32f3 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.227 2012/07/28 07:41:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.228 2012/07/28 08:20:24 graaff Exp $
+
+*rails-3.0.16 (28 Jul 2012)
+
+ 28 Jul 2012; Hans de Graaff <graaff@gentoo.org> +rails-3.0.16.ebuild:
+ Version bump for Rails 3.0.16, bug 428254.
*rails-3.1.7 (28 Jul 2012)
diff --git a/dev-ruby/rails/rails-3.0.16.ebuild b/dev-ruby/rails/rails-3.0.16.ebuild
new file mode 100644
index 000000000000..433da425c881
--- /dev/null
+++ b/dev-ruby/rails/rails-3.0.16.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-3.0.16.ebuild,v 1.1 2012/07/28 08:20:24 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.16"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ =dev-ruby/bundler-1.0*
+ ~dev-ruby/railties-${PV}"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}