summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-02 20:15:45 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-02 20:15:45 +0000
commit5514ca0f073e1c595b85e5da1d092fc255704018 (patch)
tree0b248b5346200e577fc165dd7ebe29965f09e2f9 /dev-ruby/rails
parentReplaced deprecated opts variable in logrotate init script (bug #397357) (diff)
downloadgentoo-2-5514ca0f073e1c595b85e5da1d092fc255704018.tar.gz
gentoo-2-5514ca0f073e1c595b85e5da1d092fc255704018.tar.bz2
gentoo-2-5514ca0f073e1c595b85e5da1d092fc255704018.zip
Revision bump which also installs the components of the default Rails asset pipeline by default.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog11
-rw-r--r--dev-ruby/rails/metadata.xml9
-rw-r--r--dev-ruby/rails/rails-3.1.3-r1.ebuild56
3 files changed, 73 insertions, 3 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 2542309ecb5c..cc81db3cce6b 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/rails
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.211 2011/12/31 21:46:49 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.212 2012/01/02 20:15:45 graaff Exp $
+
+*rails-3.1.3-r1 (02 Jan 2012)
+
+ 02 Jan 2012; Hans de Graaff <graaff@gentoo.org> +rails-3.1.3-r1.ebuild,
+ metadata.xml:
+ Revision bump which also installs the components of the default Rails asset
+ pipeline by default.
31 Dec 2011; Fabian Groffen <grobian@gentoo.org> rails-3.1.3.ebuild:
Add Prefix keywords, bug #396547
diff --git a/dev-ruby/rails/metadata.xml b/dev-ruby/rails/metadata.xml
index 852136183369..c021e57a32b7 100644
--- a/dev-ruby/rails/metadata.xml
+++ b/dev-ruby/rails/metadata.xml
@@ -1,5 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>ruby</herd>
+ <herd>ruby</herd>
+ <use>
+ <flag name="asset-pipeline">
+ Also install the default components for the asset pipeline.
+ These are not required but they are activated automatically
+ in new Rails projects by default.
+ </flag>
+ </use>
</pkgmetadata>
diff --git a/dev-ruby/rails/rails-3.1.3-r1.ebuild b/dev-ruby/rails/rails-3.1.3-r1.ebuild
new file mode 100644
index 000000000000..80c9871d8002
--- /dev/null
+++ b/dev-ruby/rails/rails-3.1.3-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-3.1.3-r1.ebuild,v 1.1 2012/01/02 20:15:45 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="+asset-pipeline"
+
+RDEPEND=">=app-admin/eselect-rails-0.18"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ =dev-ruby/bundler-1*
+ ~dev-ruby/railties-${PV}
+ asset-pipeline? (
+ dev-ruby/jquery-rails
+ dev-ruby/sass-rails
+ dev-ruby/uglifier
+ dev-ruby/coffee-rails
+ )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}