summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-04-20 03:43:45 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-04-20 03:43:45 +0000
commit36f1bee33337491f0c5f16ecc2c51010e15c9529 (patch)
treee3ca1e5c4b098dc30892694e6eba2c255647effc /dev-ruby/rails/rails-0.12.1.ebuild
parentVersion bump removed bad version. (diff)
downloadgentoo-2-36f1bee33337491f0c5f16ecc2c51010e15c9529.tar.gz
gentoo-2-36f1bee33337491f0c5f16ecc2c51010e15c9529.tar.bz2
gentoo-2-36f1bee33337491f0c5f16ecc2c51010e15c9529.zip
Version bump removed bad version.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-ruby/rails/rails-0.12.1.ebuild')
-rw-r--r--dev-ruby/rails/rails-0.12.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/rails/rails-0.12.1.ebuild b/dev-ruby/rails/rails-0.12.1.ebuild
new file mode 100644
index 000000000000..1832ad8dfbc9
--- /dev/null
+++ b/dev-ruby/rails/rails-0.12.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-0.12.1.ebuild,v 1.1 2005/04/20 03:43:45 pythonhead Exp $
+
+inherit ruby gems
+
+USE_RUBY="ruby18"
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+# The URL depends implicitly on the version, unfortunately. Even if you
+# change the filename on the end, it still downloads the same file.
+SRC_URI="http://rubyforge.org/frs/download.php/4158/${P}.gem"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="mysql sqlite postgres fastcgi"
+DEPEND="=dev-lang/ruby-1.8*
+ >=dev-ruby/rake-0.5.3
+ >=dev-ruby/activerecord-1.10.1
+ >=dev-ruby/actionmailer-0.9.1
+ >=dev-ruby/actionwebservice-0.7.1
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.5-r1 )
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ mysql? ( >=dev-ruby/mysql-ruby-2.5 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"
+
+