summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-17 19:39:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-17 19:39:51 +0000
commita8dc6c2568b584ff3ed8bd9be068867b82975fb2 (patch)
treebb2eb81d320381ba16f2ab252d767b29bb259eb1 /dev-ruby/rack/rack-1.0.1-r1.ebuild
parentFix aqbanking deps wrt #299144. (diff)
downloadgentoo-2-a8dc6c2568b584ff3ed8bd9be068867b82975fb2.tar.gz
gentoo-2-a8dc6c2568b584ff3ed8bd9be068867b82975fb2.tar.bz2
gentoo-2-a8dc6c2568b584ff3ed8bd9be068867b82975fb2.zip
Disable unreliable tests from both 1.0.1 and 1.1.0 ebuilds, and add jruby support for both now that it works.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rack/rack-1.0.1-r1.ebuild')
-rw-r--r--dev-ruby/rack/rack-1.0.1-r1.ebuild27
1 files changed, 19 insertions, 8 deletions
diff --git a/dev-ruby/rack/rack-1.0.1-r1.ebuild b/dev-ruby/rack/rack-1.0.1-r1.ebuild
index 7c853b33a5d8..9e8f1b353e6e 100644
--- a/dev-ruby/rack/rack-1.0.1-r1.ebuild
+++ b/dev-ruby/rack/rack-1.0.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.0.1-r1.ebuild,v 1.8 2010/01/14 15:41:28 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.0.1-r1.ebuild,v 1.9 2010/01/17 19:39:51 flameeyes Exp $
EAPI="2"
-USE_RUBY="ruby18"
+USE_RUBY="ruby18 jruby"
RUBY_FAKEGEM_DOCDIR="doc"
@@ -18,15 +18,26 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x64-solaris ~x86-solaris"
IUSE=""
-# The gem has automagic dependencies over ruby-openid,
-# memcache-client, thin and camping.
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all.
ruby_add_bdepend test dev-ruby/test-spec
-# Since the Rakefile calls specrb directly rather than loading it, we
-# cannot use it to launch the tests or only the currently-selected
-# RUBY interpreter will be tested.
+all_ruby_prepare() {
+ # Disable the test on the content-length: it not only varies on
+ # the internal implementation (and thus “needs change often” as
+ # the code says), but it also varies on the implementation (thus
+ # failing on JRuby).
+ sed -i -e '/content_length\.should\.be/s:^:#:' \
+ test/spec_rack_mock.rb || die
+}
+
each_ruby_test() {
- ${RUBY} -S specrb -Ilib:test -w -a -t "^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Auth::OpenID)" \
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S specrb -Ilib:test -w -a \
+ -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Auth::OpenID)' \
|| die "test failed for ${RUBY}"
}