summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-06-28 23:14:15 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-06-28 23:14:15 +0000
commitf44c2ca1c4a3d4b14b26755f4d4b886cc3e8db80 (patch)
tree402430179f6b9f739b1709577b0aca57a39c4cee /dev-ruby/pygments_rb
parentAdd postinst elog message about missing fonts. (diff)
downloadgentoo-2-f44c2ca1c4a3d4b14b26755f4d4b886cc3e8db80.tar.gz
gentoo-2-f44c2ca1c4a3d4b14b26755f4d4b886cc3e8db80.tar.bz2
gentoo-2-f44c2ca1c4a3d4b14b26755f4d4b886cc3e8db80.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/pygments_rb')
-rw-r--r--dev-ruby/pygments_rb/ChangeLog7
-rw-r--r--dev-ruby/pygments_rb/pygments_rb-0.6.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-ruby/pygments_rb/ChangeLog b/dev-ruby/pygments_rb/ChangeLog
index dbbdd1b79628..7c343b489c1c 100644
--- a/dev-ruby/pygments_rb/ChangeLog
+++ b/dev-ruby/pygments_rb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/pygments_rb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pygments_rb/ChangeLog,v 1.1 2014/04/07 13:10:26 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pygments_rb/ChangeLog,v 1.2 2014/06/28 23:14:15 mrueg Exp $
+
+*pygments_rb-0.6.0 (28 Jun 2014)
+
+ 28 Jun 2014; Manuel Rüger <mrueg@gentoo.org> +pygments_rb-0.6.0.ebuild:
+ Version bump.
*pygments_rb-0.5.4 (07 Apr 2014)
diff --git a/dev-ruby/pygments_rb/pygments_rb-0.6.0.ebuild b/dev-ruby/pygments_rb/pygments_rb-0.6.0.ebuild
new file mode 100644
index 000000000000..8302c6d864d0
--- /dev/null
+++ b/dev-ruby/pygments_rb/pygments_rb-0.6.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pygments_rb/pygments_rb-0.6.0.ebuild,v 1.1 2014/06/28 23:14:15 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+RUBY_FAKEGEM_NAME="pygments.rb"
+MY_P="${RUBY_FAKEGEM_NAME}-${PV}"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem python-single-r1
+
+DESCRIPTION="pygments syntax highlighting in ruby"
+HOMEPAGE="https://github.com/tmm1/pygments.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE+=" ${PYTHON_REQUIRED_USE}"
+
+RUBY_S="${MY_P}"
+
+RDEPEND+=" dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND+=" test? ( ${RDEPEND} )"
+
+ruby_add_rdepend ">=dev-ruby/yajl-ruby-1.1
+ dev-ruby/posix-spawn"
+ruby_add_bdepend "dev-ruby/rake-compiler"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile || die "sed failed"
+ python_fix_shebang lib/pygments/mentos.py
+ # we are loosing a "custom github lexer here", no idea what it is,
+ # but if we need it, it should go into dev-python/pygments
+ rm -r vendor lexers || die "removing bundled libs failed"
+}
+
+each_ruby_compile() {
+ # regenerate the lexer cache, based on the system pygments pkg
+ ${RUBY} cache-lexers.rb || die "regenerating lexer cache failed"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ ruby_fakegem_doins lexers
+}