summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-11-14 07:16:28 +0000
committerHans de Graaff <graaff@gentoo.org>2012-11-14 07:16:28 +0000
commit909d038c2dcda697281716333459de2389e7bf8b (patch)
tree7557aa3db02488a532f0a5cbed664e46ce18a57a /dev-ruby/pry
parentRemove this version again since the compatibility issues where elsewhere. (diff)
downloadgentoo-2-909d038c2dcda697281716333459de2389e7bf8b.tar.gz
gentoo-2-909d038c2dcda697281716333459de2389e7bf8b.tar.bz2
gentoo-2-909d038c2dcda697281716333459de2389e7bf8b.zip
Revision bump to depend on the right slot of slop, and to actually write the right gemspec with fixed dependencies. Fixes bug 443054. Drop ppc64 due to unkeyworded slop slot.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/pry')
-rw-r--r--dev-ruby/pry/ChangeLog13
-rw-r--r--dev-ruby/pry/pry-0.9.7.4-r1.ebuild44
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/pry/ChangeLog b/dev-ruby/pry/ChangeLog
index 143988dff6ed..d84041bbd231 100644
--- a/dev-ruby/pry/ChangeLog
+++ b/dev-ruby/pry/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-ruby/pry
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pry/ChangeLog,v 1.9 2012/11/14 04:06:27 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pry/ChangeLog,v 1.10 2012/11/14 07:16:28 graaff Exp $
+
+ 14 Nov 2012; Hans de Graaff <graaff@gentoo.org> +pry-0.9.7.4-r1.ebuild:
+ Revision bump to depend on the right slot of slop, and to actually write the
+ right gemspec with fixed dependencies. Fixes bug 443054. Drop ppc64 due to
+ unkeyworded slop slot.
+
+*pry-0.9.7.4-r1 (14 Nov 2012)
+
+ 14 Nov 2012; Hans de Graaff <graaff@gentoo.org> +pry-0.9.7.4-r1.ebuild:
+ Revision bump to depend on the right slot of slop, and to actually write the
+ right gemspec with fixed dependencies. Fixes bug 443054.
14 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org> pry-0.9.7.4.ebuild:
Bump dependency on ruby_parser as reported by antarus.
diff --git a/dev-ruby/pry/pry-0.9.7.4-r1.ebuild b/dev-ruby/pry/pry-0.9.7.4-r1.ebuild
new file mode 100644
index 000000000000..ea58d3293b13
--- /dev/null
+++ b/dev-ruby/pry/pry-0.9.7.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pry/pry-0.9.7.4-r1.ebuild,v 1.1 2012/11/14 07:16:28 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pry is a powerful alternative to the standard IRB shell for Ruby."
+HOMEPAGE="https://github.com/pry/pry/wiki"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_rdepend ">=dev-ruby/ruby_parser-2.3.1
+ >=dev-ruby/coderay-0.9.8
+ >=dev-ruby/slop-2.1.0:0
+ >=dev-ruby/method_source-0.6.7
+ !!dev-python/pry"
+
+ruby_add_bdepend "test? ( >=dev-ruby/bacon-1.1.0 >=dev-ruby/open4-1.0.1 )"
+
+all_ruby_prepare() {
+ # Make version dependencies more lenient to avoid problems with
+ # compatible upgrades.
+ sed -i -e 's/~> 2.0.5/>= 2.0.5/' \
+ -e 's/~> 0.9.8/>= 0.9.8/' \
+ -e 's/~> 2.1.0/~> 2.1/' \
+ -e 's/~> 0.6.7/>= 0.6.7/' \
+ pry.gemspec || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Itest -a -q || die
+}