summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-07-16 13:04:42 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-07-16 13:04:42 +0000
commit5409d4ac7871073baf8bae52fe4452d9e17889f9 (patch)
tree5c800505e307e438ca0583b08e4e76f5d3ffb045 /dev-ruby/posix-spawn
parentPin x11-libs/libkscreen dependency to SLOT 4. (diff)
downloadgentoo-2-5409d4ac7871073baf8bae52fe4452d9e17889f9.tar.gz
gentoo-2-5409d4ac7871073baf8bae52fe4452d9e17889f9.tar.bz2
gentoo-2-5409d4ac7871073baf8bae52fe4452d9e17889f9.zip
Add version with ruby21 support. Cleanup old.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/posix-spawn')
-rw-r--r--dev-ruby/posix-spawn/ChangeLog8
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.8_p20140630-r1.ebuild (renamed from dev-ruby/posix-spawn/posix-spawn-0.3.8.ebuild)9
2 files changed, 14 insertions, 3 deletions
diff --git a/dev-ruby/posix-spawn/ChangeLog b/dev-ruby/posix-spawn/ChangeLog
index 5943de61c0d6..83b2a05c3f2d 100644
--- a/dev-ruby/posix-spawn/ChangeLog
+++ b/dev-ruby/posix-spawn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/posix-spawn
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/ChangeLog,v 1.7 2014/07/16 05:24:53 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/ChangeLog,v 1.8 2014/07/16 13:04:42 mrueg Exp $
+
+*posix-spawn-0.3.8_p20140630-r1 (16 Jul 2014)
+
+ 16 Jul 2014; Manuel Rüger <mrueg@gentoo.org>
+ +posix-spawn-0.3.8_p20140630-r1.ebuild, -posix-spawn-0.3.8.ebuild:
+ Add version with ruby21 support. Cleanup old.
16 Jul 2014; Hans de Graaff <graaff@gentoo.org>
posix-spawn-0.3.8_p20140630.ebuild:
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.8.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.8_p20140630-r1.ebuild
index 13c5da9c02b3..fabec0f28720 100644
--- a/dev-ruby/posix-spawn/posix-spawn-0.3.8.ebuild
+++ b/dev-ruby/posix-spawn/posix-spawn-0.3.8_p20140630-r1.ebuild
@@ -1,25 +1,30 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/posix-spawn-0.3.8.ebuild,v 1.2 2014/05/21 01:45:51 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/posix-spawn-0.3.8_p20140630-r1.ebuild,v 1.1 2014/07/16 13:04:42 mrueg Exp $
EAPI=5
# jruby → should be supported but does not work with "rake compile"
-USE_RUBY="ruby19"
+USE_RUBY="ruby19 ruby20 ruby21"
KEYWORDS="~amd64"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
+RUBY_FAKEGEM_VERSION="0.3.8.20140630"
inherit ruby-fakegem
DESCRIPTION="The posix-spawn library aims to implement a subset of the Ruby 1.9 Process::spawn"
HOMEPAGE="https://github.com/rtomayko/posix-spawn/"
+COMMIT_ID="25a0806ce0335faf958834d9dd6a41ff2288fa56"
+SRC_URI="https://github.com/rtomayko/posix-spawn/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT LGPL-2.1"
SLOT="0"
IUSE="test"
+RUBY_S="${PN}-${COMMIT_ID}"
+
each_ruby_configure() {
${RUBY} -Cext extconf.rb || die
}