summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-04-01 06:47:12 +0000
committerHans de Graaff <graaff@gentoo.org>2010-04-01 06:47:12 +0000
commit3fc6f41eef170955fc9858686c3d81bd014f1157 (patch)
tree51ee069b63b73d956fb6da77eb1979eea1760cd1 /dev-ruby/polyglot
parentstable x86, bug 307265 (diff)
downloadgentoo-2-3fc6f41eef170955fc9858686c3d81bd014f1157.tar.gz
gentoo-2-3fc6f41eef170955fc9858686c3d81bd014f1157.tar.bz2
gentoo-2-3fc6f41eef170955fc9858686c3d81bd014f1157.zip
Version bump.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/polyglot')
-rw-r--r--dev-ruby/polyglot/ChangeLog7
-rw-r--r--dev-ruby/polyglot/polyglot-0.3.1.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-ruby/polyglot/ChangeLog b/dev-ruby/polyglot/ChangeLog
index be74167dfcea..20eef4750725 100644
--- a/dev-ruby/polyglot/ChangeLog
+++ b/dev-ruby/polyglot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/polyglot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/ChangeLog,v 1.11 2010/03/04 07:48:49 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/ChangeLog,v 1.12 2010/04/01 06:47:12 graaff Exp $
+
+*polyglot-0.3.1 (01 Apr 2010)
+
+ 01 Apr 2010; Hans de Graaff <graaff@gentoo.org> +polyglot-0.3.1.ebuild:
+ Version bump.
*polyglot-0.3.0 (04 Mar 2010)
diff --git a/dev-ruby/polyglot/polyglot-0.3.1.ebuild b/dev-ruby/polyglot/polyglot-0.3.1.ebuild
new file mode 100644
index 000000000000..5c00c3813c9a
--- /dev/null
+++ b/dev-ruby/polyglot/polyglot-0.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/polyglot-0.3.1.ebuild,v 1.1 2010/04/01 06:47:12 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Polyglot provides support for fully-custom DSLs."
+HOMEPAGE="http://polyglot.rubyforge.org/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend test virtual/ruby-test-unit
+
+each_ruby_test() {
+ ${RUBY} test/test_polyglot.rb || die "tests failed"
+}