summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-30 06:54:08 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-30 06:54:08 +0000
commit5d337ca10f7b9bd90749efc174274c0f4b69e5b6 (patch)
tree39d3d29ce6403fc3ad9a08fc5bc3fd5b31aa0af5 /dev-ruby/pg
parentVersion bump. (diff)
downloadgentoo-2-5d337ca10f7b9bd90749efc174274c0f4b69e5b6.tar.gz
gentoo-2-5d337ca10f7b9bd90749efc174274c0f4b69e5b6.tar.bz2
gentoo-2-5d337ca10f7b9bd90749efc174274c0f4b69e5b6.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/ChangeLog7
-rw-r--r--dev-ruby/pg/pg-0.11.0.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-ruby/pg/ChangeLog b/dev-ruby/pg/ChangeLog
index be716c449f20..9c8365be0412 100644
--- a/dev-ruby/pg/ChangeLog
+++ b/dev-ruby/pg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/pg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.31 2011/04/27 05:48:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.32 2011/04/30 06:54:08 graaff Exp $
+
+*pg-0.11.0 (30 Apr 2011)
+
+ 30 Apr 2011; Hans de Graaff <graaff@gentoo.org> +pg-0.11.0.ebuild:
+ Version bump.
21 Apr 2011; Hans de Graaff <graaff@gentoo.org> pg-0.9.0-r1.ebuild:
Add missing rdoc dependency, reported in bug 358723.
diff --git a/dev-ruby/pg/pg-0.11.0.ebuild b/dev-ruby/pg/pg-0.11.0.ebuild
new file mode 100644
index 000000000000..053314ac0072
--- /dev/null
+++ b/dev-ruby/pg/pg-0.11.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.11.0.ebuild,v 1.1 2011/04/30 06:54:08 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TEST_TASK=""
+
+RUBY_FAKEGEM_TASK_DOC="apidocs"
+RUBY_FAKEGEM_DOCDIR="docs/api"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
+HOMEPAGE="http://bitbucket.org/ged/ruby-pg/"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ dev-db/postgresql-base"
+DEPEND="${DEPEND}
+ dev-db/postgresql-base
+ test? ( dev-db/postgresql-server )"
+
+ruby_add_bdepend "
+ doc? (
+ dev-ruby/rake-compiler
+ dev-ruby/rubygems
+ || ( >=dev-ruby/yard-0.6.1 dev-ruby/rdoc ) )
+ test? ( dev-ruby/rspec:2 )"
+
+each_ruby_configure() {
+ pushd ext
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+ popd
+}
+
+each_ruby_compile() {
+ pushd ext
+ emake CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed"
+ popd
+ cp ext/*.so lib || die
+}
+
+each_ruby_test() {
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ ${RUBY} -Ilib -S rspec -fs spec/*_spec.rb || die "spec failed"
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+}