summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-26 07:49:12 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-26 07:49:12 +0000
commit5a0f160e8b515c6410132d05165bf555a3f1f01f (patch)
treeefcd3328419df859bdc34ee8a164db8b38a79d0c /dev-ruby/pg
parentppc64 stable wrt #348499 (diff)
downloadgentoo-2-5a0f160e8b515c6410132d05165bf555a3f1f01f.tar.gz
gentoo-2-5a0f160e8b515c6410132d05165bf555a3f1f01f.tar.bz2
gentoo-2-5a0f160e8b515c6410132d05165bf555a3f1f01f.zip
Add back this version since it is the last one using rspec:0.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/ChangeLog6
-rw-r--r--dev-ruby/pg/pg-0.10.0.ebuild4
-rw-r--r--dev-ruby/pg/pg-0.9.0-r1.ebuild58
3 files changed, 65 insertions, 3 deletions
diff --git a/dev-ruby/pg/ChangeLog b/dev-ruby/pg/ChangeLog
index fcd019d4e55e..b34fabb9acc1 100644
--- a/dev-ruby/pg/ChangeLog
+++ b/dev-ruby/pg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/pg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.24 2011/02/26 07:33:58 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.25 2011/02/26 07:49:12 graaff Exp $
+
+ 26 Feb 2011; Hans de Graaff <graaff@gentoo.org> +pg-0.9.0-r1.ebuild,
+ pg-0.10.0.ebuild:
+ Add back this version since it is the last one using rspec:0.
26 Feb 2011; Hans de Graaff <graaff@gentoo.org> -pg-0.9.0-r1.ebuild:
Remove old version.
diff --git a/dev-ruby/pg/pg-0.10.0.ebuild b/dev-ruby/pg/pg-0.10.0.ebuild
index c79da48d3bc6..3d6eaff79677 100644
--- a/dev-ruby/pg/pg-0.10.0.ebuild
+++ b/dev-ruby/pg/pg-0.10.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.10.0.ebuild,v 1.1 2011/01/02 15:42:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.10.0.ebuild,v 1.2 2011/02/26 07:49:12 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19"
+USE_RUBY="ruby18 ree18"
RUBY_FAKEGEM_TEST_TASK=""
diff --git a/dev-ruby/pg/pg-0.9.0-r1.ebuild b/dev-ruby/pg/pg-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..4c2315143145
--- /dev/null
+++ b/dev-ruby/pg/pg-0.9.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.9.0-r1.ebuild,v 1.9 2011/02/26 07:49:12 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TEST_TASK=""
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="docs/api"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
+HOMEPAGE="http://bitbucket.org/ged/ruby-pg/"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ dev-db/postgresql-base"
+DEPEND="${DEPEND}
+ dev-db/postgresql-base
+ test? ( dev-db/postgresql-server )"
+
+# For the rakefile (and thus doc generation and testing) to work as
+# intended, you need both rake-compiler _and_ the real RubyGems
+# package; what is shipped with Ruby 1.9 is not good enough as it
+# lacks the packaging tasks for Rake.
+ruby_add_bdepend "
+ doc? (
+ dev-ruby/rake-compiler
+ dev-ruby/rubygems )
+ test? ( dev-ruby/rspec:0 )"
+
+each_ruby_configure() {
+ pushd ext
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+ popd
+}
+
+each_ruby_compile() {
+ pushd ext
+ emake CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed"
+ popd
+ cp ext/*.so lib || die
+}
+
+each_ruby_test() {
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ ${RUBY} -Ilib -S spec -Du -fs spec/*_spec.rb || die "spec failed"
+}