summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-05 10:59:26 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-05 10:59:26 +0000
commit37ff9018abc9ea05be07304abf43772ae5c68803 (patch)
tree64ae945b2e8045daa50600058e4332840232bd5a /dev-ruby/oniguruma
parentRemove LICENSE file from dodoc (diff)
downloadgentoo-2-37ff9018abc9ea05be07304abf43772ae5c68803.tar.gz
gentoo-2-37ff9018abc9ea05be07304abf43772ae5c68803.tar.bz2
gentoo-2-37ff9018abc9ea05be07304abf43772ae5c68803.zip
Fix dependencies. Install documentation.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/oniguruma')
-rw-r--r--dev-ruby/oniguruma/ChangeLog8
-rw-r--r--dev-ruby/oniguruma/oniguruma-1.1.0-r2.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-ruby/oniguruma/ChangeLog b/dev-ruby/oniguruma/ChangeLog
index 0393d7730561..ece829a8610c 100644
--- a/dev-ruby/oniguruma/ChangeLog
+++ b/dev-ruby/oniguruma/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/oniguruma
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oniguruma/ChangeLog,v 1.6 2010/05/23 16:52:55 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oniguruma/ChangeLog,v 1.7 2010/06/05 10:59:26 graaff Exp $
+
+*oniguruma-1.1.0-r2 (05 Jun 2010)
+
+ 05 Jun 2010; Hans de Graaff <graaff@gentoo.org>
+ +oniguruma-1.1.0-r2.ebuild:
+ Fix dependencies. Install documentation.
23 May 2010; Hans de Graaff <graaff@gentoo.org> oniguruma-1.1.0-r1.ebuild:
Move the shared object in the compile phase so that it is the right place
diff --git a/dev-ruby/oniguruma/oniguruma-1.1.0-r2.ebuild b/dev-ruby/oniguruma/oniguruma-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..7410c5b50472
--- /dev/null
+++ b/dev-ruby/oniguruma/oniguruma-1.1.0-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oniguruma/oniguruma-1.1.0-r2.ebuild,v 1.1 2010/06/05 10:59:26 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt Syntax.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings to the Oniguruma"
+HOMEPAGE="http://oniguruma.rubyforge.org/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="${DEPEND} dev-libs/oniguruma"
+RDEPEND="${RDEPEND} dev-libs/oniguruma"
+
+RUBY_PATCHES=( "${P}-unmonkey.patch" )
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/hoe )
+ test? (
+ dev-ruby/hoe
+ virtual/ruby-test-unit
+ )"
+
+each_ruby_configure() {
+ pushd ext >& /dev/null
+ ${RUBY} extconf.rb
+ popd >& /dev/null
+}
+
+each_ruby_compile() {
+ pushd ext >& /dev/null
+ emake || die "Compilation failed."
+ popd >& /dev/null
+ mv ext/oregexp.so lib || die "Unable to move oregexp.so"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+}