summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-05-23 16:52:55 +0000
committerHans de Graaff <graaff@gentoo.org>2010-05-23 16:52:55 +0000
commit789f93c68936e4fb3ae33ed499f8c89a6192e8dc (patch)
tree97b3119b6ccc7a62ae83cc7dd2f4cb088c7474ae /dev-ruby/oniguruma/oniguruma-1.1.0-r1.ebuild
parentx86 stable wrt bug #313023 (diff)
downloadgentoo-2-789f93c68936e4fb3ae33ed499f8c89a6192e8dc.tar.gz
gentoo-2-789f93c68936e4fb3ae33ed499f8c89a6192e8dc.tar.bz2
gentoo-2-789f93c68936e4fb3ae33ed499f8c89a6192e8dc.zip
Move the shared object in the compile phase so that it is the right place for tests. Fixes #321193.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/oniguruma/oniguruma-1.1.0-r1.ebuild')
-rw-r--r--dev-ruby/oniguruma/oniguruma-1.1.0-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/oniguruma/oniguruma-1.1.0-r1.ebuild b/dev-ruby/oniguruma/oniguruma-1.1.0-r1.ebuild
index 5cb3091deeb8..e68bf54318d2 100644
--- a/dev-ruby/oniguruma/oniguruma-1.1.0-r1.ebuild
+++ b/dev-ruby/oniguruma/oniguruma-1.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oniguruma/oniguruma-1.1.0-r1.ebuild,v 1.2 2010/05/22 15:32:55 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oniguruma/oniguruma-1.1.0-r1.ebuild,v 1.3 2010/05/23 16:52:55 graaff Exp $
EAPI="2"
USE_RUBY="ruby18"
@@ -40,9 +40,9 @@ each_ruby_compile() {
pushd ext >& /dev/null
emake || die "Compilation failed."
popd >& /dev/null
+ mv ext/oregexp.so lib || die "Unable to move oregexp.so"
}
each_ruby_install() {
- mv ext/oregexp.so lib || die "Unable to move oregexp.so"
each_fakegem_install
}