summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-15 14:36:40 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-15 14:36:40 +0000
commit5965d30fc650c110c925173540ee932c378a2a3f (patch)
treed71c500b0fbd88b572a384c2779c3aaaea187a52 /dev-ruby/ohai
parentStable on alpha, bug #366687 (diff)
downloadgentoo-2-5965d30fc650c110c925173540ee932c378a2a3f.tar.gz
gentoo-2-5965d30fc650c110c925173540ee932c378a2a3f.tar.bz2
gentoo-2-5965d30fc650c110c925173540ee932c378a2a3f.zip
Version bump. Drop x86 keyword due to new sigar dependency, bug 398989.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ohai')
-rw-r--r--dev-ruby/ohai/ChangeLog9
-rw-r--r--dev-ruby/ohai/ohai-0.6.10.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-ruby/ohai/ChangeLog b/dev-ruby/ohai/ChangeLog
index dcb9dafc475b..3bfcbf5541c1 100644
--- a/dev-ruby/ohai/ChangeLog
+++ b/dev-ruby/ohai/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ohai
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ChangeLog,v 1.7 2011/10/16 09:40:37 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ChangeLog,v 1.8 2012/01/15 14:36:40 graaff Exp $
+
+*ohai-0.6.10 (15 Jan 2012)
+
+ 15 Jan 2012; Hans de Graaff <graaff@gentoo.org> +ohai-0.6.10.ebuild:
+ Version bump. Drop x86 keyword due to new sigar dependency, bug 398989.
16 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ohai-0.5.6-r1.ebuild,
-ohai-0.6.2.ebuild:
diff --git a/dev-ruby/ohai/ohai-0.6.10.ebuild b/dev-ruby/ohai/ohai-0.6.10.ebuild
new file mode 100644
index 000000000000..6af3cabca479
--- /dev/null
+++ b/dev-ruby/ohai/ohai-0.6.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-0.6.10.ebuild,v 1.1 2012/01/15 14:36:40 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ohai profiles your system and emits JSON"
+HOMEPAGE="http://wiki.opscode.com/display/chef/Ohai"
+SRC_URI="https://github.com/opscode/${PN}/tarball/${PV} -> ${P}.tgz"
+RUBY_S="opscode-${PN}-*"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/sigar )"
+
+ruby_add_rdepend "
+ dev-ruby/yajl-ruby
+ dev-ruby/mixlib-cli
+ dev-ruby/mixlib-config
+ dev-ruby/mixlib-log
+ >=dev-ruby/systemu-2.2.0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ # Be more lenient to work with versions of systemu that we have in
+ # the tree.
+ sed -i -e 's/~> 2.2.0/>= 2.2.0/' ohai.gemspec || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman docs/man/man1/ohai.1
+}