summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-11 18:47:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-11 18:47:41 +0000
commit940d57984d4a3e416fefe61be90279fbbfb13ae2 (patch)
tree42a0faea75c7308951efc7585455d9e469a854e3 /dev-ruby/nokogiri
parenteclean-kernel has been moved to app-admin/. (diff)
downloadgentoo-2-940d57984d4a3e416fefe61be90279fbbfb13ae2.tar.gz
gentoo-2-940d57984d4a3e416fefe61be90279fbbfb13ae2.tar.bz2
gentoo-2-940d57984d4a3e416fefe61be90279fbbfb13ae2.zip
Version bump; tests are partially restricted but this solves JRuby issues among others.
(Portage version: 2.2.0_alpha103/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/nokogiri')
-rw-r--r--dev-ruby/nokogiri/ChangeLog8
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.5.2.ebuild99
2 files changed, 106 insertions, 1 deletions
diff --git a/dev-ruby/nokogiri/ChangeLog b/dev-ruby/nokogiri/ChangeLog
index 2629d48af689..246e1bae1cab 100644
--- a/dev-ruby/nokogiri/ChangeLog
+++ b/dev-ruby/nokogiri/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/nokogiri
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.70 2012/05/06 15:13:04 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.71 2012/05/11 18:47:41 flameeyes Exp $
+
+*nokogiri-1.5.2 (11 May 2012)
+
+ 11 May 2012; Diego E. Pettenò <flameeyes@gentoo.org> +nokogiri-1.5.2.ebuild:
+ Version bump; tests are partially restricted but this solves JRuby issues
+ among others.
06 May 2012; Kacper Kowalik <xarthisius@gentoo.org> nokogiri-1.4.4-r1.ebuild:
ppc64 stable wrt #369573
diff --git a/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild b/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild
new file mode 100644
index 000000000000..9cb10d1b99fa
--- /dev/null
+++ b/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild,v 1.1 2012/05/11 18:47:41 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc CHANGELOG.ja.rdoc README.rdoc README.ja.rdoc"
+
+inherit ruby-fakegem eutils multilib
+
+DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
+HOMEPAGE="http://nokogiri.rubyforge.org/"
+LICENSE="MIT"
+SRC_URI="https://github.com/tenderlove/nokogiri/tarball/v${PV} -> ${P}.tgz"
+RUBY_S="tenderlove-nokogiri-*"
+
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ dev-libs/libxml2
+ dev-libs/libxslt"
+DEPEND="${DEPEND}
+ dev-libs/libxml2
+ dev-libs/libxslt"
+
+# The tests require _minitest_, not the virtual; what is shipped with
+# Ruby 1.9 is *not* enough, unfortunately
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ dev-ruby/rexical
+ dev-ruby/hoe
+ dev-ruby/rdoc
+ dev-ruby/racc
+ test? ( dev-ruby/minitest )"
+
+# tests currently work only with Ruby 1.9; there is a small issue with
+# JRuby, but it's insignificant, while 1.8 and EE 1.8 are failing due to
+# the hashing order changes.
+RESTRICT="ruby_targets_ruby18? ( test )
+ ruby_targets_ree18? ( test )
+ ruby_targets_jruby? ( test )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/tasks\/cross_compile/s:^:#:' \
+ -e '/:test.*prerequisites/s:^:#:' \
+ Rakefile || die
+ # Remove the cross compilation options since they interfere with
+ # native building.
+ sed -i -e 's/cross_compile = true/cross_compile = false/' Rakefile || die
+ sed -i -e '/cross_config_options/d' Rakefile || die
+}
+
+each_ruby_configure() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ ${RUBY} -Cext/${PN} extconf.rb \
+ --with-zlib-include="${EPREFIX}"/usr/include \
+ --with-zlib-lib="${EPREFIX}"/$(get_libdir) \
+ --with-iconv-include="${EPREFIX}"/usr/include \
+ --with-iconv-lib="${EPREFIX}"/$(get_libdir) \
+ --with-xml2-include="${EPREFIX}"/usr/include/libxml2 \
+ --with-xml2-lib="${EPREFIX}"/usr/$(get_libdir) \
+ --with-xslt-dir="${EPREFIX}"/usr \
+ --with-iconvlib=iconv \
+ || die "extconf.rb failed"
+ ;;
+ esac
+}
+
+each_ruby_compile() {
+ case ${RUBY} in
+ *jruby)
+ ${RUBY} -S rake compile || die
+ ;;
+ *)
+ if ! [[ -f lib/nokogiri/css/tokenizer.rb ]]; then
+ ${RUBY} -S rake lib/nokogiri/css/tokenizer.rb || die "rexical failed"
+ fi
+
+ if ! [[ -f lib/nokogiri/css/parser.rb ]]; then
+ ${RUBY} -S rake lib/nokogiri/css/parser.rb || die "racc failed"
+ fi
+
+ emake -Cext/${PN} \
+ CFLAGS="${CFLAGS} -fPIC" \
+ archflag="${LDFLAGS}" || die "make extension failed"
+ cp -l ext/${PN}/${PN}$(get_modname) lib/${PN}/ || die
+ ;;
+ esac
+}