summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-09 10:15:44 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-09 10:15:44 +0000
commit2c3ed251fc43094b29bb144e5aa59a58e50c7609 (patch)
tree91f36f04d0f0315020cdfc9a5e529134f59fd508 /dev-ruby/nokogiri
parentVersion bump - bug #374507. EAPI bump. Fix SRC_URI and HOMEPAGE. (diff)
downloadgentoo-2-2c3ed251fc43094b29bb144e5aa59a58e50c7609.tar.gz
gentoo-2-2c3ed251fc43094b29bb144e5aa59a58e50c7609.tar.bz2
gentoo-2-2c3ed251fc43094b29bb144e5aa59a58e50c7609.zip
Version bump. The ffi interface is no longer supported, so jruby has been dropped. It should be possible to add that back later by building the native jruby support.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/nokogiri')
-rw-r--r--dev-ruby/nokogiri/ChangeLog9
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.5.0.ebuild68
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-ruby/nokogiri/ChangeLog b/dev-ruby/nokogiri/ChangeLog
index 69719b88aac9..7ed5f401bd0b 100644
--- a/dev-ruby/nokogiri/ChangeLog
+++ b/dev-ruby/nokogiri/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/nokogiri
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.55 2011/07/09 09:48:59 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.56 2011/07/09 10:15:44 graaff Exp $
+
+*nokogiri-1.5.0 (09 Jul 2011)
+
+ 09 Jul 2011; Hans de Graaff <graaff@gentoo.org> +nokogiri-1.5.0.ebuild:
+ Version bump. The ffi interface is no longer supported, so jruby has been
+ dropped. It should be possible to add that back later by building the native
+ jruby support.
09 Jul 2011; Hans de Graaff <graaff@gentoo.org> -nokogiri-1.4.4.ebuild:
Remove old version.
diff --git a/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild b/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild
new file mode 100644
index 000000000000..843ed80822f5
--- /dev/null
+++ b/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild,v 1.1 2011/07/09 10:15:44 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc CHANGELOG.ja.rdoc README.rdoc README.ja.rdoc"
+
+inherit ruby-fakegem eutils multilib
+
+DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
+HOMEPAGE="http://nokogiri.rubyforge.org/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ dev-libs/libxml2
+ dev-libs/libxslt"
+DEPEND="${DEPEND}
+ dev-libs/libxml2
+ dev-libs/libxslt"
+
+# The tests require _minitest_, not the virtual; what is shipped with
+# Ruby 1.9 is *not* enough, unfortunately
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ dev-ruby/rexical
+ dev-ruby/hoe
+ dev-ruby/racc
+ doc? ( dev-ruby/rdoc )
+ test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/tasks\/cross_compile/s:^:#:' \
+ -e '/:test.*prerequisites/s:^:#:' \
+ Rakefile || die
+ # Remove the cross compilation options since they interfere with
+ # native building.
+ sed -i -e 's/cross_compile = true/cross_compile = false/' Rakefile || die
+ sed -i -e '/cross_config_options/d' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ if ! [[ -f lib/nokogiri/css/tokenizer.rb ]]; then
+ ${RUBY} -S rake lib/nokogiri/css/tokenizer.rb || die "rexical failed"
+ fi
+
+ emake -Cext/${PN} \
+ CFLAGS="${CFLAGS} -fPIC" \
+ archflag="${LDFLAGS}" || die "make extension failed"
+ cp -l ext/${PN}/${PN}$(get_modname) lib/${PN}/ || die
+}
+
+each_ruby_test() {
+ each_fakegem_test
+}