summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-28 08:31:08 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-28 08:31:08 +0000
commitb566caecb05ac7e6d88f81971932629347fefbb2 (patch)
treef245d8662134486773572827d12deed3859fea3a /dev-ruby/narray
parentDrop ruby19 from stable version. (diff)
downloadgentoo-2-b566caecb05ac7e6d88f81971932629347fefbb2.tar.gz
gentoo-2-b566caecb05ac7e6d88f81971932629347fefbb2.tar.bz2
gentoo-2-b566caecb05ac7e6d88f81971932629347fefbb2.zip
Revision bump to drop ruby19 from stable version.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/narray')
-rw-r--r--dev-ruby/narray/ChangeLog8
-rw-r--r--dev-ruby/narray/narray-0.6.0.1-r1.ebuild54
-rw-r--r--dev-ruby/narray/narray-0.6.0.1.ebuild4
3 files changed, 63 insertions, 3 deletions
diff --git a/dev-ruby/narray/ChangeLog b/dev-ruby/narray/ChangeLog
index a4315fd9e9cf..0d665f3d61f8 100644
--- a/dev-ruby/narray/ChangeLog
+++ b/dev-ruby/narray/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/narray
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.48 2011/10/23 15:30:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.49 2011/12/28 08:31:07 graaff Exp $
+
+*narray-0.6.0.1-r1 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> narray-0.6.0.1.ebuild,
+ +narray-0.6.0.1-r1.ebuild:
+ Revision bump to drop ruby19 from stable version.
23 Oct 2011; Raúl Porcel <armin76@gentoo.org> narray-0.5.9_p6.ebuild,
narray-0.6.0.1.ebuild:
diff --git a/dev-ruby/narray/narray-0.6.0.1-r1.ebuild b/dev-ruby/narray/narray-0.6.0.1-r1.ebuild
new file mode 100644
index 000000000000..d1ae1b5d5de0
--- /dev/null
+++ b/dev-ruby/narray/narray-0.6.0.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.6.0.1-r1.ebuild,v 1.1 2011/12/28 08:31:08 graaff Exp $
+
+EAPI=4
+
+# jruby → native extension
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.en README.ja SPEC.en SPEC.ja"
+
+RUBY_FAKEGEM_VERSION="${PV/_p/.}"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Numerical N-dimensional Array class"
+HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
+SRC_URI="mirror://rubyforge/${PN}/${P/_/}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+all_ruby_prepare() {
+ # the tests aren't really written to be a testsuite, so the
+ # failure cases will literally fail; ignore all of those ad
+ # instead expect that the rest won't fail.
+ sed -i -e '/[fF]ollowing will fail/,$ s:^:#:' \
+ test/*.rb || die "sed failed"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed"
+ cp -l ${PN}$(get_modname) lib || die "copy of ${PN}$(get_modname) failed"
+}
+
+each_ruby_test() {
+ for unit in test/*; do
+ # Skip over the FFTW test because it needs a package we don't
+ # have in tree.
+ [[ ${unit} == test/testfftw.rb ]] && continue
+
+ ${RUBY} -Ilib ${unit} || die "test ${unit} failed"
+ done
+}
diff --git a/dev-ruby/narray/narray-0.6.0.1.ebuild b/dev-ruby/narray/narray-0.6.0.1.ebuild
index b07e8770a9ed..8bdb6661a144 100644
--- a/dev-ruby/narray/narray-0.6.0.1.ebuild
+++ b/dev-ruby/narray/narray-0.6.0.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.6.0.1.ebuild,v 1.5 2011/10/23 15:30:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.6.0.1.ebuild,v 1.6 2011/12/28 08:31:07 graaff Exp $
EAPI=4
# jruby → native extension
-USE_RUBY="ruby18 ree18 ruby19"
+USE_RUBY="ruby18 ree18"
RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_TASK_DOC=""