summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-13 09:23:38 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-13 09:23:38 +0000
commitfe285fddda3af4cf649156f759b99395f2bd87a9 (patch)
treed6dbafb7a3aeb58bedd0432059307c01db521c66 /dev-ruby/mocha
parentVersion bump (diff)
downloadgentoo-2-fe285fddda3af4cf649156f759b99395f2bd87a9.tar.gz
gentoo-2-fe285fddda3af4cf649156f759b99395f2bd87a9.tar.bz2
gentoo-2-fe285fddda3af4cf649156f759b99395f2bd87a9.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/mocha')
-rw-r--r--dev-ruby/mocha/ChangeLog7
-rw-r--r--dev-ruby/mocha/mocha-0.9.12.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/mocha/ChangeLog b/dev-ruby/mocha/ChangeLog
index 5f95db02d1b7..63cbc85bd7c4 100644
--- a/dev-ruby/mocha/ChangeLog
+++ b/dev-ruby/mocha/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/mocha
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/ChangeLog,v 1.30 2011/02/04 07:37:18 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/ChangeLog,v 1.31 2011/02/13 09:23:38 graaff Exp $
+
+*mocha-0.9.12 (13 Feb 2011)
+
+ 13 Feb 2011; Hans de Graaff <graaff@gentoo.org> +mocha-0.9.12.ebuild:
+ Version bump.
*mocha-0.9.11 (04 Feb 2011)
diff --git a/dev-ruby/mocha/mocha-0.9.12.ebuild b/dev-ruby/mocha/mocha-0.9.12.ebuild
new file mode 100644
index 000000000000..3ebf2f5f40a9
--- /dev/null
+++ b/dev-ruby/mocha/mocha-0.9.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/mocha-0.9.12.ebuild,v 1.1 2011/02/13 09:23:38 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc RELEASE.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for mocking and stubbing using a syntax like that of JMock, and SchMock"
+HOMEPAGE="http://mocha.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? ( virtual/ruby-test-unit )
+ doc? ( dev-ruby/coderay )"
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ rake examples || die
+ fi
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*.rb || die
+}