summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-07-22 07:37:12 +0000
committerHans de Graaff <graaff@gentoo.org>2012-07-22 07:37:12 +0000
commitd29f68fb6911fd061f6a5288641659c178690c27 (patch)
treef7a627bde7d5f1f9777497f7ef896b9f6e6000c7 /dev-ruby/mocha
parentNew ebuild for ansi2html. (diff)
downloadgentoo-2-d29f68fb6911fd061f6a5288641659c178690c27.tar.gz
gentoo-2-d29f68fb6911fd061f6a5288641659c178690c27.tar.bz2
gentoo-2-d29f68fb6911fd061f6a5288641659c178690c27.zip
Fix examples generation to work with all coderay versions.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/mocha')
-rw-r--r--dev-ruby/mocha/ChangeLog5
-rw-r--r--dev-ruby/mocha/mocha-0.10.5.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-ruby/mocha/ChangeLog b/dev-ruby/mocha/ChangeLog
index 00b94e83258a..f1a4f05a09aa 100644
--- a/dev-ruby/mocha/ChangeLog
+++ b/dev-ruby/mocha/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/mocha
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/ChangeLog,v 1.62 2012/06/27 16:58:31 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/ChangeLog,v 1.63 2012/07/22 07:37:12 graaff Exp $
+
+ 22 Jul 2012; Hans de Graaff <graaff@gentoo.org> mocha-0.10.5.ebuild:
+ Fix examples generation to work with all coderay versions.
27 Jun 2012; Hans de Graaff <graaff@gentoo.org> mocha-0.11.4.ebuild:
Run tests directly instead of via rake to avoid unneeded dependency on yard,
diff --git a/dev-ruby/mocha/mocha-0.10.5.ebuild b/dev-ruby/mocha/mocha-0.10.5.ebuild
index daa54634e2ff..9fd3a48081f6 100644
--- a/dev-ruby/mocha/mocha-0.10.5.ebuild
+++ b/dev-ruby/mocha/mocha-0.10.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/mocha-0.10.5.ebuild,v 1.5 2012/06/13 17:39:49 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/mocha-0.10.5.ebuild,v 1.6 2012/07/22 07:37:12 graaff Exp $
EAPI=4
USE_RUBY="ruby18 ree18 ruby19 jruby"
@@ -30,6 +30,9 @@ ruby_add_rdepend "dev-ruby/metaclass" #metaclass ~> 0.0.1
all_ruby_prepare() {
sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
+
+ # Use syntax that works with all versions of coderay
+ sed -i -e 's/html.div/html(:wrap => :div)/' Rakefile || die
}
all_ruby_compile() {