summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-01-02 22:57:18 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-01-02 22:57:18 +0000
commitc81473c95a3272c8adea24bfe435353b0fe9436d (patch)
treef0dc086fb66809df2cb34921c00219636cdf8651 /dev-ruby/mixlib-shellout
parentRemove old (bash-completion.eclass cleanup). (diff)
downloadgentoo-2-c81473c95a3272c8adea24bfe435353b0fe9436d.tar.gz
gentoo-2-c81473c95a3272c8adea24bfe435353b0fe9436d.tar.bz2
gentoo-2-c81473c95a3272c8adea24bfe435353b0fe9436d.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/mixlib-shellout')
-rw-r--r--dev-ruby/mixlib-shellout/ChangeLog9
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-1.6.1.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-ruby/mixlib-shellout/ChangeLog b/dev-ruby/mixlib-shellout/ChangeLog
index 066a4e89cefa..40a16ada5682 100644
--- a/dev-ruby/mixlib-shellout/ChangeLog
+++ b/dev-ruby/mixlib-shellout/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/mixlib-shellout
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/ChangeLog,v 1.10 2014/10/08 12:32:38 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/ChangeLog,v 1.11 2015/01/02 22:57:18 mrueg Exp $
+
+*mixlib-shellout-1.6.1 (02 Jan 2015)
+
+ 02 Jan 2015; Manuel Rüger <mrueg@gentoo.org> +mixlib-shellout-1.6.1.ebuild:
+ Version bump.
*mixlib-shellout-1.6.0 (08 Oct 2014)
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-1.6.1.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-1.6.1.ebuild
new file mode 100644
index 000000000000..956820a923e9
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-1.6.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/mixlib-shellout-1.6.1.ebuild,v 1.1 2015/01/02 22:57:18 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRA_DOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="http://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}