summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-22 06:22:27 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-22 06:22:27 +0000
commita1f73fee300b8c13b3f9f08f5b4ecfe3c1206ad2 (patch)
tree52e58e966dea10081fb0f53feeed29173bce8797 /dev-ruby/mixlib-log
parentVersion bump. Use SLOTs as defined by chef usage. (diff)
downloadgentoo-2-a1f73fee300b8c13b3f9f08f5b4ecfe3c1206ad2.tar.gz
gentoo-2-a1f73fee300b8c13b3f9f08f5b4ecfe3c1206ad2.tar.bz2
gentoo-2-a1f73fee300b8c13b3f9f08f5b4ecfe3c1206ad2.zip
EAPI=5. Add ruby20.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/mixlib-log')
-rw-r--r--dev-ruby/mixlib-log/ChangeLog7
-rw-r--r--dev-ruby/mixlib-log/mixlib-log-1.4.1-r1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ruby/mixlib-log/ChangeLog b/dev-ruby/mixlib-log/ChangeLog
index f8ff4418a581..c4613682b5fa 100644
--- a/dev-ruby/mixlib-log/ChangeLog
+++ b/dev-ruby/mixlib-log/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/mixlib-log
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-log/ChangeLog,v 1.14 2014/04/05 23:32:53 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-log/ChangeLog,v 1.15 2014/07/22 06:22:27 graaff Exp $
+
+*mixlib-log-1.4.1-r1 (22 Jul 2014)
+
+ 22 Jul 2014; Hans de Graaff <graaff@gentoo.org> +mixlib-log-1.4.1-r1.ebuild:
+ EAPI=5. Add ruby20.
05 Apr 2014; Manuel Rüger <mrueg@gentoo.org> mixlib-log-1.4.1.ebuild:
Remove ree18 and ruby18 target.
diff --git a/dev-ruby/mixlib-log/mixlib-log-1.4.1-r1.ebuild b/dev-ruby/mixlib-log/mixlib-log-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..d4a6fe7c308b
--- /dev/null
+++ b/dev-ruby/mixlib-log/mixlib-log-1.4.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-log/mixlib-log-1.4.1-r1.ebuild,v 1.1 2014/07/22 06:22:27 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRA_DOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple class based Log mechanism"
+HOMEPAGE="http://github.com/opscode/mixlib-log"
+SRC_URI="https://github.com/opscode/${PN}/tarball/${PV} -> ${P}.tgz"
+RUBY_S="opscode-${PN}-*"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:2
+ dev-util/cucumber
+)"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on bundler.
+ rm Gemfile || die
+}
+
+each_ruby_test() {
+ ruby-ng_rspec
+ ruby-ng_cucumber
+}