summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-28 09:19:53 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-28 09:19:53 +0000
commitd0e818d3c9c03f62315c4be7f9013e8710fb32bb (patch)
treea5f0401f11167505f798fcb92c895f3a26c4456a /dev-ruby/minitest
parentRemove old versions. (diff)
downloadgentoo-2-d0e818d3c9c03f62315c4be7f9013e8710fb32bb.tar.gz
gentoo-2-d0e818d3c9c03f62315c4be7f9013e8710fb32bb.tar.bz2
gentoo-2-d0e818d3c9c03f62315c4be7f9013e8710fb32bb.zip
Version bump: better backwards compatibility, refactored runner, benchmark support, and more.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/minitest')
-rw-r--r--dev-ruby/minitest/ChangeLog8
-rw-r--r--dev-ruby/minitest/minitest-2.0.2.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/minitest/ChangeLog b/dev-ruby/minitest/ChangeLog
index 229df2fb1c71..10b1f0eaf50c 100644
--- a/dev-ruby/minitest/ChangeLog
+++ b/dev-ruby/minitest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/minitest
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.28 2010/12/28 09:15:56 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.29 2010/12/28 09:19:53 graaff Exp $
+
+*minitest-2.0.2 (28 Dec 2010)
+
+ 28 Dec 2010; Hans de Graaff <graaff@gentoo.org> +minitest-2.0.2.ebuild:
+ Version bump: better backwards compatibility, refactored runner, benchmark
+ support, and more.
27 Dec 2010; Fabian Groffen <grobian@gentoo.org> minitest-1.7.2.ebuild:
Marked ~x64-solaris
diff --git a/dev-ruby/minitest/minitest-2.0.2.ebuild b/dev-ruby/minitest/minitest-2.0.2.ebuild
new file mode 100644
index 000000000000..829c351963d6
--- /dev/null
+++ b/dev-ruby/minitest/minitest-2.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-2.0.2.ebuild,v 1.1 2010/12/28 09:19:53 graaff Exp $
+
+EAPI=2
+# jruby → tests fail, reported upstream
+# http://rubyforge.org/tracker/index.php?func=detail&aid=27657&group_id=1040&atid=4097
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="minitest/unit is a small and fast replacement for ruby's huge and slow test/unit."
+HOMEPAGE="http://rubyforge.org/projects/bfts"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/hoe )
+ test? (
+ virtual/ruby-test-unit
+ dev-ruby/hoe
+ )"
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ eqawarn "Skipping tests on JRuby, bug 321055."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}