summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-09-07 11:27:14 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-09-07 11:27:14 +0000
commit5ef35dab1b6143c6aba580b9860cb0974973bc7a (patch)
tree1bc87279c8752bf1ac7b6a967c5e70e863e6f24a /dev-ruby/minitest
parentVersion bump. (diff)
downloadgentoo-2-5ef35dab1b6143c6aba580b9860cb0974973bc7a.tar.gz
gentoo-2-5ef35dab1b6143c6aba580b9860cb0974973bc7a.tar.bz2
gentoo-2-5ef35dab1b6143c6aba580b9860cb0974973bc7a.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/minitest')
-rw-r--r--dev-ruby/minitest/ChangeLog7
-rw-r--r--dev-ruby/minitest/minitest-5.0.7.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/minitest/ChangeLog b/dev-ruby/minitest/ChangeLog
index 7618bafdc135..b730ae630262 100644
--- a/dev-ruby/minitest/ChangeLog
+++ b/dev-ruby/minitest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/minitest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.127 2013/08/18 18:45:05 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.128 2013/09/07 11:27:14 mrueg Exp $
+
+*minitest-5.0.7 (07 Sep 2013)
+
+ 07 Sep 2013; Manuel Rüger <mrueg@gentoo.org> +minitest-5.0.7.ebuild:
+ Version bump.
18 Aug 2013; Hans de Graaff <graaff@gentoo.org> minitest-5.0.6.ebuild:
Move minitest 5.x to a separate slot because rails will depend on a specific
diff --git a/dev-ruby/minitest/minitest-5.0.7.ebuild b/dev-ruby/minitest/minitest-5.0.7.ebuild
new file mode 100644
index 000000000000..5f4981a43814
--- /dev/null
+++ b/dev-ruby/minitest/minitest-5.0.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-5.0.7.ebuild,v 1.1 2013/09/07 11:27:14 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="minitest/unit is a small and fast replacement for ruby's huge and slow test/unit."
+HOMEPAGE="https://github.com/seattlerb/minitest"
+
+LICENSE="MIT"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/hoe dev-ruby/rdoc )
+ test? ( dev-ruby/hoe )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Make sure __jtrap is available in all threads. This should
+ # be fixed in jruby 1.7.x
+ sed -i -e '8i trap :INFO do ; end' lib/minitest/parallel_each.rb || die
+
+ # Avoid failures. Most of these look like low-level jruby
+ # differences and it looks like these were not run properly
+ # in previous versions.
+ local command="/${t}/,/^ end/ s:^:#:"
+ for t in test_return_mock_does_not_raise test_mock_args_does_not_raise test_stub_block test_stub_value ; do
+ sed -i -e "${command}" test/minitest/test_minitest_mock.rb || die
+ done
+ for t in test_run_failing test_run_skip test_run_error test_run_skip_verbose test_run_error_teardown test_runnable_methods_random test_assert_throws_different test_to_s_error_in_test_and_teardown test_run_filtered_including_suite_name_string test_run_filtered_string_method_only test_run_filtered_including_suite_name ; do
+ sed -i -e "${command}" test/minitest/test_minitest_unit.rb || die
+ done
+ for t in test_name2 "needs to verify throw" ; do
+ sed -i -e "${command}" test/minitest/test_minitest_spec.rb || die
+ done
+ sed -i -e '/test_report_error/,/^ end/ s:^:#:' test/minitest/test_minitest_reporter.rb || die
+ ;;
+ esac
+}