summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-04 15:33:51 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-04 15:33:51 +0000
commit04d02ad0ad45400976d94648244d3d332f7261a4 (patch)
treede8f4aca35e77d8e2e166ef0065ed3dbff4c6739 /dev-ruby/minitest
parentVersion bump. (diff)
downloadgentoo-2-04d02ad0ad45400976d94648244d3d332f7261a4.tar.gz
gentoo-2-04d02ad0ad45400976d94648244d3d332f7261a4.tar.bz2
gentoo-2-04d02ad0ad45400976d94648244d3d332f7261a4.zip
Version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/minitest')
-rw-r--r--dev-ruby/minitest/ChangeLog7
-rw-r--r--dev-ruby/minitest/minitest-5.4.2.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-ruby/minitest/ChangeLog b/dev-ruby/minitest/ChangeLog
index 4f4ae95f2e3b..fc3caa2b75cd 100644
--- a/dev-ruby/minitest/ChangeLog
+++ b/dev-ruby/minitest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/minitest
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.164 2014/08/30 10:19:57 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.165 2014/10/04 15:33:51 mrueg Exp $
+
+*minitest-5.4.2 (04 Oct 2014)
+
+ 04 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +minitest-5.4.2.ebuild:
+ Version bump.
*minitest-5.4.1 (30 Aug 2014)
diff --git a/dev-ruby/minitest/minitest-5.4.2.ebuild b/dev-ruby/minitest/minitest-5.4.2.ebuild
new file mode 100644
index 000000000000..f77d2d331f93
--- /dev/null
+++ b/dev-ruby/minitest/minitest-5.4.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-5.4.2.ebuild,v 1.1 2014/10/04 15:33:51 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="minitest/unit is a small and fast replacement for ruby's huge and slow test/unit"
+HOMEPAGE="https://github.com/seattlerb/minitest"
+
+LICENSE="MIT"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Make sure __jtrap is available in all threads. This should
+ # be fixed in jruby 1.7.x
+ sed -i -e '8i trap :INFO do ; end' lib/minitest/parallel.rb || die
+
+ # Avoid failures. Most of these look like low-level jruby
+ # differences and it looks like these were not run properly
+ # in previous versions.
+ for t in test_return_mock_does_not_raise test_mock_args_does_not_raise test_stub_block test_stub_value ; do
+ local command="/${t}/,/^ end/ s:^:#:"
+ sed -i -e "${command}" test/minitest/test_minitest_mock.rb || die
+ done
+ for t in test_run_failing test_run_skip test_run_error test_run_skip_verbose test_run_error_teardown test_runnable_methods_random test_assert_throws_different test_to_s_error_in_test_and_teardown test_run_filtered_including_suite_name_string test_run_filtered_string_method_only test_run_filtered_including_suite_name ; do
+ command="/${t}/,/^ end/ s:^:#:"
+ sed -i -e "${command}" test/minitest/test_minitest_unit.rb || die
+ done
+ for t in test_name2 "needs to verify throw" ; do
+ command="/${t}/,/^ end/ s:^:#:"
+ sed -i -e "${command}" test/minitest/test_minitest_spec.rb || die
+ done
+ sed -i -e '/test_report_error/,/^ end/ s:^:#:' test/minitest/test_minitest_reporter.rb || die
+ ;;
+ *rbx)
+ # Avoid a single failing test for rbx while we are testing
+ # and bootstrapping it.
+ sed -i -e '/test_mock_args_does_not_raise/,/^ end/ s:^:#:' test/minitest/test_minitest_mock.rb || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e "Dir['**/test_*.rb'].each{|f| require f}" || die "Tests failed"
+}