summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-21 07:17:30 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-21 07:17:30 +0000
commit26b2a9f974ef2fdfbecf102c89fecfd9bc75e9f5 (patch)
tree6a455421f787f9d588e9fb7ba63e8324b285215c /dev-ruby/mini_magick
parentclean up (diff)
downloadgentoo-2-26b2a9f974ef2fdfbecf102c89fecfd9bc75e9f5.tar.gz
gentoo-2-26b2a9f974ef2fdfbecf102c89fecfd9bc75e9f5.tar.bz2
gentoo-2-26b2a9f974ef2fdfbecf102c89fecfd9bc75e9f5.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/mini_magick')
-rw-r--r--dev-ruby/mini_magick/ChangeLog7
-rw-r--r--dev-ruby/mini_magick/mini_magick-1.3.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/mini_magick/ChangeLog b/dev-ruby/mini_magick/ChangeLog
index f06fceed5138..d5a36230c2d5 100644
--- a/dev-ruby/mini_magick/ChangeLog
+++ b/dev-ruby/mini_magick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/mini_magick
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/ChangeLog,v 1.2 2010/05/22 15:25:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/ChangeLog,v 1.3 2010/07/21 07:17:30 graaff Exp $
+
+*mini_magick-1.3.1 (21 Jul 2010)
+
+ 21 Jul 2010; Hans de Graaff <graaff@gentoo.org> +mini_magick-1.3.1.ebuild:
+ Version bump.
22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
mini_magick-1.2.5.ebuild:
diff --git a/dev-ruby/mini_magick/mini_magick-1.3.1.ebuild b/dev-ruby/mini_magick/mini_magick-1.3.1.ebuild
new file mode 100644
index 000000000000..6d5125c629d3
--- /dev/null
+++ b/dev-ruby/mini_magick/mini_magick-1.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/mini_magick-1.3.1.ebuild,v 1.1 2010/07/21 07:17:30 graaff Exp $
+
+EAPI=2
+
+# jruby → test_tempfile_at_path_after_format fails with jruby 1.3.1,
+# sounds like a bug in JRuby itself, or the code not being compatible.
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Manipulate images with minimal use of memory."
+HOMEPAGE="http://github.com/probablycorey/mini_magick"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# It's only used at runtime in this case because this extension only
+# _calls_ the commands. But when we run tests we're going to need tiff
+# and jpeg support at a minimum.
+RDEPEND="media-gfx/imagemagick"
+DEPEND="test? ( media-gfx/imagemagick[tiff,jpeg] )"
+
+# tests are known to fail under imagemagick 6.5 at least, reported upstream:
+# http://github.com/probablycorey/mini_magick/issues/#issue/2
+# update: still fails with imagemagick 6.6.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+ruby_add_rdepend ">=dev-ruby/subexec-0.0.4"
+
+all_ruby_prepare() {
+ # remove executable bit from all files
+ find "${S}" -type f -exec chmod -x {} +
+
+ # Remove spec definition part because the gemspec file is not included
+ sed -i -e '/gemspec/,$ d' Rakefile || die
+
+ # Use ImageMagick for the tests since that is the version we depend on.
+ sed -i -e '/:gm/d' test/image_test.rb || die
+}