summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-09 07:16:48 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-09 07:16:48 +0000
commit3ba8cf57450647eced1c7c8ce6b6df07eafb3882 (patch)
treeac2dc5c293519f0e8622d573675475e73ff30334 /dev-ruby/method_source
parentInitial import. Implicit dependency for new versions of mechanize. (diff)
downloadgentoo-2-3ba8cf57450647eced1c7c8ce6b6df07eafb3882.tar.gz
gentoo-2-3ba8cf57450647eced1c7c8ce6b6df07eafb3882.tar.bz2
gentoo-2-3ba8cf57450647eced1c7c8ce6b6df07eafb3882.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/method_source')
-rw-r--r--dev-ruby/method_source/ChangeLog7
-rw-r--r--dev-ruby/method_source/method_source-0.7.1.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/method_source/ChangeLog b/dev-ruby/method_source/ChangeLog
index 6d0f779d5a3d..8c8bb5bb9432 100644
--- a/dev-ruby/method_source/ChangeLog
+++ b/dev-ruby/method_source/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/method_source
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/ChangeLog,v 1.6 2012/03/11 12:53:50 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/ChangeLog,v 1.7 2012/04/09 07:16:48 graaff Exp $
+
+*method_source-0.7.1 (09 Apr 2012)
+
+ 09 Apr 2012; Hans de Graaff <graaff@gentoo.org> +method_source-0.7.1.ebuild:
+ Version bump.
11 Mar 2012; Brent Baude <ranger@gentoo.org> method_source-0.7.0.ebuild:
Marking method_source-0.7.0 ~ppc64 for bug 388357
diff --git a/dev-ruby/method_source/method_source-0.7.1.ebuild b/dev-ruby/method_source/method_source-0.7.1.ebuild
new file mode 100644
index 000000000000..ffe2f44b3432
--- /dev/null
+++ b/dev-ruby/method_source/method_source-0.7.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/method_source-0.7.1.ebuild,v 1.1 2012/04/09 07:16:48 graaff Exp $
+
+EAPI=4
+# jruby crashes on parsing the metadata.
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="method_source.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the source code for a method."
+HOMEPAGE="http://github.com/banister/method_source"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc64"
+
+ruby_add_bdepend "test? ( >=dev-ruby/bacon-1.1.0 )"
+
+each_ruby_test() {
+ ${RUBY} -I. -S bacon -k test/test.rb || die "Tests failed."
+}