summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-07-25 01:18:00 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-07-25 01:18:00 +0000
commit0e94c06488483e7da5d3511871cf0d324b0d09d4 (patch)
tree8f3acabdb40c9cdae964d3c941fc4cb028469d61 /dev-ruby/method_source
parentAdd ruby21 target. Thanks to longlene. (diff)
downloadgentoo-2-0e94c06488483e7da5d3511871cf0d324b0d09d4.tar.gz
gentoo-2-0e94c06488483e7da5d3511871cf0d324b0d09d4.tar.bz2
gentoo-2-0e94c06488483e7da5d3511871cf0d324b0d09d4.zip
Add ruby21 target. Thanks to longlene.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/method_source')
-rw-r--r--dev-ruby/method_source/ChangeLog7
-rw-r--r--dev-ruby/method_source/method_source-0.8.2-r3.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-ruby/method_source/ChangeLog b/dev-ruby/method_source/ChangeLog
index fc97ade31043..e63a1b8b04cd 100644
--- a/dev-ruby/method_source/ChangeLog
+++ b/dev-ruby/method_source/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/method_source
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/ChangeLog,v 1.22 2014/05/21 02:00:28 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/ChangeLog,v 1.23 2014/07/25 01:18:00 mrueg Exp $
+
+*method_source-0.8.2-r3 (25 Jul 2014)
+
+ 25 Jul 2014; Manuel Rüger <mrueg@gentoo.org> +method_source-0.8.2-r3.ebuild:
+ Add ruby21 target. Thanks to longlene.
21 May 2014; Manuel Rüger <mrueg@gentoo.org> -method_source-0.8.2-r1.ebuild,
method_source-0.8.2-r2.ebuild:
diff --git a/dev-ruby/method_source/method_source-0.8.2-r3.ebuild b/dev-ruby/method_source/method_source-0.8.2-r3.ebuild
new file mode 100644
index 000000000000..27fafbb51ec7
--- /dev/null
+++ b/dev-ruby/method_source/method_source-0.8.2-r3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/method_source-0.8.2-r3.ebuild,v 1.1 2014/07/25 01:17:59 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the source code for a method"
+HOMEPAGE="http://github.com/banister/method_source"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+ruby_add_bdepend "test? ( >=dev-ruby/bacon-1.1.0 )"
+
+each_ruby_test() {
+ ${RUBY} -I. -S bacon -k test/test.rb || die "Tests failed."
+}