summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-08-28 09:29:38 +0000
committerHans de Graaff <graaff@gentoo.org>2011-08-28 09:29:38 +0000
commitc8aea5ecd4c8f5ac202aff6427e663af5db9a21e (patch)
treeb9ab650cca3c89111c7857ee035d0026da25c30a /dev-ruby/markaby/markaby-0.7.2.ebuild
parentChange version scheme (diff)
downloadgentoo-2-c8aea5ecd4c8f5ac202aff6427e663af5db9a21e.tar.gz
gentoo-2-c8aea5ecd4c8f5ac202aff6427e663af5db9a21e.tar.bz2
gentoo-2-c8aea5ecd4c8f5ac202aff6427e663af5db9a21e.zip
Fix spec order issue in a different way to cater to even more variation.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/markaby/markaby-0.7.2.ebuild')
-rw-r--r--dev-ruby/markaby/markaby-0.7.2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/markaby/markaby-0.7.2.ebuild b/dev-ruby/markaby/markaby-0.7.2.ebuild
index 8b5bfba9d26f..956064e8c162 100644
--- a/dev-ruby/markaby/markaby-0.7.2.ebuild
+++ b/dev-ruby/markaby/markaby-0.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/markaby/markaby-0.7.2.ebuild,v 1.1 2011/08/24 06:00:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/markaby/markaby-0.7.2.ebuild,v 1.2 2011/08/28 09:29:38 graaff Exp $
EAPI=2
USE_RUBY="ruby18 ree18"
@@ -28,5 +28,5 @@ ruby_add_rdepend ">=dev-ruby/builder-2.0.0"
all_ruby_prepare() {
# Add missing require to fix spec. The associated failure depended
# on load order of the specs, bug 343693.
- sed -i -e '1irequire "markaby/tilt"' spec/markaby/tilt_spec.rb || die
+ sed -i -e "10irequire 'markaby/tilt'" spec/spec_helper.rb || die
}