summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-02-14 10:31:28 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-02-14 10:31:28 +0000
commit804d978b45a68c4e4fea6e3361d6498ff7065edc (patch)
tree32ea038f5afe3bd1cca79cbe8f3ab1263a09b7a5 /dev-ruby/map
parentStable for amd64 wrt bug #499840 (diff)
downloadgentoo-2-804d978b45a68c4e4fea6e3361d6498ff7065edc.tar.gz
gentoo-2-804d978b45a68c4e4fea6e3361d6498ff7065edc.tar.bz2
gentoo-2-804d978b45a68c4e4fea6e3361d6498ff7065edc.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/map')
-rw-r--r--dev-ruby/map/ChangeLog10
-rw-r--r--dev-ruby/map/map-6.5.2.ebuild36
2 files changed, 43 insertions, 3 deletions
diff --git a/dev-ruby/map/ChangeLog b/dev-ruby/map/ChangeLog
index e734f3ea3b10..476d4af9db68 100644
--- a/dev-ruby/map/ChangeLog
+++ b/dev-ruby/map/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/map
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/ChangeLog,v 1.11 2013/10/22 18:03:08 graaff Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/ChangeLog,v 1.12 2014/02/14 10:31:28 mrueg Exp $
+
+*map-6.5.2 (14 Feb 2014)
+
+ 14 Feb 2014; Manuel Rüger <mrueg@gentoo.org> +map-6.5.2.ebuild:
+ Version bump.
*map-6.5.1 (22 Oct 2013)
@@ -51,4 +56,3 @@
11 Oct 2011; Hans de Graaff <graaff@gentoo.org> +map-4.6.1.ebuild,
+metadata.xml:
Initial import. New dependency for dev-ruby/main.
-
diff --git a/dev-ruby/map/map-6.5.2.ebuild b/dev-ruby/map/map-6.5.2.ebuild
new file mode 100644
index 000000000000..4f9e84bd1f4b
--- /dev/null
+++ b/dev-ruby/map/map-6.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/map-6.5.2.ebuild,v 1.1 2014/02/14 10:31:28 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+RUBY_FAKEGEM_GEMSPEC="map.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A string/symbol indifferent ordered hash that works in all rubies."
+HOMEPAGE="http://github.com/ahoward/map"
+
+LICENSE="|| ( Ruby BSD-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby18)
+ epatch "${FILESDIR}/ruby18-failing-tests.patch"
+ epatch "${FILESDIR}/${PN}-6.5.1-ruby18-failing-tests.patch"
+ ;;
+ *jruby)
+ epatch "${FILESDIR}/${PN}-6.5.1-ruby18-failing-tests.patch"
+ ;;
+ *)
+ ;;
+ esac
+}