summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 01:15:12 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 01:15:12 +0000
commitc74df693ee54e7eb2f9f7ec832504e28b0c4d90c (patch)
tree1c450d968081fd813c44a35328069a04bd497e6d /dev-ruby/loquacious
parentPort to rspec helper for testing. Bump to EAPI 4. Breaks cyclic dependency wi... (diff)
downloadgentoo-2-c74df693ee54e7eb2f9f7ec832504e28b0c4d90c.tar.gz
gentoo-2-c74df693ee54e7eb2f9f7ec832504e28b0c4d90c.tar.bz2
gentoo-2-c74df693ee54e7eb2f9f7ec832504e28b0c4d90c.zip
Port to rspec helper for testing. Only build documentation with USE=doc.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/loquacious')
-rw-r--r--dev-ruby/loquacious/ChangeLog6
-rw-r--r--dev-ruby/loquacious/loquacious-1.9.1.ebuild15
2 files changed, 11 insertions, 10 deletions
diff --git a/dev-ruby/loquacious/ChangeLog b/dev-ruby/loquacious/ChangeLog
index 711dd23d62f1..b0b04642a3ab 100644
--- a/dev-ruby/loquacious/ChangeLog
+++ b/dev-ruby/loquacious/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/loquacious
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/loquacious/ChangeLog,v 1.16 2012/02/02 22:02:19 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/loquacious/ChangeLog,v 1.17 2012/08/14 01:15:12 flameeyes Exp $
+
+ 14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> loquacious-1.9.1.ebuild:
+ Port to rspec helper for testing. Only build documentation with USE=doc.
02 Feb 2012; Thomas Kahle <tomka@gentoo.org> loquacious-1.9.1.ebuild:
~x86 per bug 325471
@@ -74,4 +77,3 @@
31 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+loquacious-1.4.1.ebuild, +metadata.xml:
Initial import of bones and related dependencies.
-
diff --git a/dev-ruby/loquacious/loquacious-1.9.1.ebuild b/dev-ruby/loquacious/loquacious-1.9.1.ebuild
index b7db5bc69478..47ab31b27b6b 100644
--- a/dev-ruby/loquacious/loquacious-1.9.1.ebuild
+++ b/dev-ruby/loquacious/loquacious-1.9.1.ebuild
@@ -1,11 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/loquacious/loquacious-1.9.1.ebuild,v 1.2 2012/02/02 22:02:19 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/loquacious/loquacious-1.9.1.ebuild,v 1.3 2012/08/14 01:15:12 flameeyes Exp $
EAPI=4
USE_RUBY="ruby18 ruby19 jruby ree18"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
@@ -20,19 +23,15 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.6.0:2 )"
-
all_ruby_prepare() {
# Remove metadata because it confuses jruby.
rm ../metadata || die
}
all_ruby_compile() {
- rdoc lib || die "Documentation generation failed."
-}
-
-each_ruby_test() {
- ${RUBY} -S rspec spec || die "Tests failed."
+ if use doc; then
+ rdoc lib || die "Documentation generation failed."
+ fi
}
all_ruby_install() {