summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-09 06:24:03 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-09 06:24:03 +0000
commitb0d4a2db04bbc740b843d8a14facf9eab97e85ae (patch)
treec421f710f7b1db6e4100ac982768db7b57c17762 /dev-ruby/log4r/log4r-1.1.8.ebuild
parentVersion bump (diff)
downloadgentoo-2-b0d4a2db04bbc740b843d8a14facf9eab97e85ae.tar.gz
gentoo-2-b0d4a2db04bbc740b843d8a14facf9eab97e85ae.tar.bz2
gentoo-2-b0d4a2db04bbc740b843d8a14facf9eab97e85ae.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/log4r/log4r-1.1.8.ebuild')
-rw-r--r--dev-ruby/log4r/log4r-1.1.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/log4r/log4r-1.1.8.ebuild b/dev-ruby/log4r/log4r-1.1.8.ebuild
new file mode 100644
index 000000000000..40490972dfda
--- /dev/null
+++ b/dev-ruby/log4r/log4r-1.1.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/log4r/log4r-1.1.8.ebuild,v 1.1 2010/06/09 06:24:03 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# There are no working tests atm, to be checked on next version bump.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Log4r is a comprehensive and flexible logging library written in
+Ruby for use in Ruby programs."
+HOMEPAGE="http://log4r.sourceforge.net/"
+IUSE=""
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+}