summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-09-22 17:17:27 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-09-22 17:17:27 +0000
commit43a6dd8a74819f271ce97584e93d17e1c1000367 (patch)
tree53f1d1ef9fefabb819e6d36defd4a6cc8a40c47a /dev-ruby/locale/locale-2.0.9.ebuild
parentVersion bump. (diff)
downloadgentoo-2-43a6dd8a74819f271ce97584e93d17e1c1000367.tar.gz
gentoo-2-43a6dd8a74819f271ce97584e93d17e1c1000367.tar.bz2
gentoo-2-43a6dd8a74819f271ce97584e93d17e1c1000367.zip
Version bump.
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/locale/locale-2.0.9.ebuild')
-rw-r--r--dev-ruby/locale/locale-2.0.9.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/locale/locale-2.0.9.ebuild b/dev-ruby/locale/locale-2.0.9.ebuild
new file mode 100644
index 000000000000..fe58aade4123
--- /dev/null
+++ b/dev-ruby/locale/locale-2.0.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/locale-2.0.9.ebuild,v 1.1 2013/09/22 17:17:27 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc/reference"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.rdoc doc/text/news.md"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby library which provides basic APIs for localization."
+HOMEPAGE="https://github.com/ruby-gettext/locale"
+LICENSE="|| ( Ruby GPL-2 )"
+SRC_URI="https://github.com/ruby-gettext/locale/archive/${PV}.tar.gz -> ${P}-git.tgz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-macos"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/test-unit-rr )"
+
+all_ruby_prepare() {
+ sed -i -e '/notify/ s:^:#:' test/run-test.rb || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples || die
+}