summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-10-12 05:50:10 +0000
committerHans de Graaff <graaff@gentoo.org>2012-10-12 05:50:10 +0000
commit660a9cf5f7fa8ecf5e4446ae41532bae6a887d26 (patch)
tree8a1dac5e13c3adc93f5982075cfa22f3936391eb /dev-ruby/listen
parentBump for #432284 (diff)
downloadgentoo-2-660a9cf5f7fa8ecf5e4446ae41532bae6a887d26.tar.gz
gentoo-2-660a9cf5f7fa8ecf5e4446ae41532bae6a887d26.tar.bz2
gentoo-2-660a9cf5f7fa8ecf5e4446ae41532bae6a887d26.zip
Version bump.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/listen')
-rw-r--r--dev-ruby/listen/ChangeLog7
-rw-r--r--dev-ruby/listen/listen-0.5.3.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/listen/ChangeLog b/dev-ruby/listen/ChangeLog
index 47d23a8508be..fd6760c5949a 100644
--- a/dev-ruby/listen/ChangeLog
+++ b/dev-ruby/listen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/listen
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/listen/ChangeLog,v 1.8 2012/09/29 15:21:11 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/listen/ChangeLog,v 1.9 2012/10/12 05:50:10 graaff Exp $
+
+*listen-0.5.3 (12 Oct 2012)
+
+ 12 Oct 2012; Hans de Graaff <graaff@gentoo.org> +listen-0.5.3.ebuild:
+ Version bump.
29 Sep 2012; Fabian Groffen <grobian@gentoo.org> listen-0.5.2.ebuild:
Marked ~x64-macos
diff --git a/dev-ruby/listen/listen-0.5.3.ebuild b/dev-ruby/listen/listen-0.5.3.ebuild
new file mode 100644
index 000000000000..df8cff64985e
--- /dev/null
+++ b/dev-ruby/listen/listen-0.5.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/listen/listen-0.5.3.ebuild,v 1.1 2012/10/12 05:50:10 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Listens to file modifications and notifies you about the changes."
+HOMEPAGE="https://github.com/guard/listen"
+SRC_URI="https://github.com/guard/listen/tarball/v${PV} -> ${P}-git.tgz"
+RUBY_S="guard-listen-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x64-macos"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rb-inotify-0.8.8"