summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-29 18:09:37 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-29 18:09:37 +0000
commit3764e9eebabc67d045ad33bbd86601c43b3f8790 (patch)
tree2fdf0f008cf3171add9796e1d67a1ea088e5e1be /dev-ruby/libxml
parentStable for ppc, wrt bug #489854 (diff)
downloadgentoo-2-3764e9eebabc67d045ad33bbd86601c43b3f8790.tar.gz
gentoo-2-3764e9eebabc67d045ad33bbd86601c43b3f8790.tar.bz2
gentoo-2-3764e9eebabc67d045ad33bbd86601c43b3f8790.zip
Cleanup old.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/libxml')
-rw-r--r--dev-ruby/libxml/ChangeLog7
-rw-r--r--dev-ruby/libxml/files/libxml-2.6.0-fix-test.patch19
-rw-r--r--dev-ruby/libxml/libxml-2.4.0.ebuild67
3 files changed, 6 insertions, 87 deletions
diff --git a/dev-ruby/libxml/ChangeLog b/dev-ruby/libxml/ChangeLog
index 4076abfee0c2..4c0b2fcc7880 100644
--- a/dev-ruby/libxml/ChangeLog
+++ b/dev-ruby/libxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/libxml
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.95 2014/10/29 17:53:28 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.96 2014/10/29 18:09:37 mrueg Exp $
+
+ 29 Oct 2014; Manuel Rüger <mrueg@gentoo.org>
+ -files/libxml-2.6.0-fix-test.patch, -libxml-2.4.0.ebuild,
+ libxml-2.7.0-r2.ebuild:
+ Cleanup old.
29 Oct 2014; Agostino Sarubbo <ago@gentoo.org> libxml-2.7.0-r1.ebuild:
Stable for ppc, wrt bug #489854
diff --git a/dev-ruby/libxml/files/libxml-2.6.0-fix-test.patch b/dev-ruby/libxml/files/libxml-2.6.0-fix-test.patch
deleted file mode 100644
index 827002205efb..000000000000
--- a/dev-ruby/libxml/files/libxml-2.6.0-fix-test.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-commit 25b4a6e53c894609b9e4a66bf288423d212407e2
-Author: julp <poinsot.julien@gmail.com>
-Date: Sun May 5 21:36:47 2013 +0200
-
- To fix XML::Writer.set_quote_char UT, wrong expected string (#63)
-
-diff --git a/test/tc_writer.rb b/test/tc_writer.rb
-index fcc5e0f..ab89763 100644
---- a/test/tc_writer.rb
-+++ b/test/tc_writer.rb
-@@ -250,7 +250,7 @@ class TestWriter < Test::Unit::TestCase
- assert(writer.end_attribute)
- end
- end
-- assert_equal(writer.result.strip!, "<?xml version=\"1.0\"?>\n<root><child abc='def'>ghi</child></root>")
-+ assert(writer.result.strip!.end_with? "<root abc='def'/>")
- end
- end
-
diff --git a/dev-ruby/libxml/libxml-2.4.0.ebuild b/dev-ruby/libxml/libxml-2.4.0.ebuild
deleted file mode 100644
index 9bcc99542496..000000000000
--- a/dev-ruby/libxml/libxml-2.4.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.4.0.ebuild,v 1.9 2014/08/05 16:00:44 mrueg Exp $
-
-EAPI=2
-
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_NAME="libxml-ruby"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster"
-HOMEPAGE="https://github.com/xml4r/libxml-ruby"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="${RDEPEND} dev-libs/libxml2"
-DEPEND="${DEPEND} dev-libs/libxml2"
-
-ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
-
-all_ruby_prepare() {
- # Remove grancher tasks only needed for publishing the website
- sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
-
- # We don't have the hanna template available.
- sed -i -e 's/hanna/rake/' Rakefile || die
-
- # Remove rake-compiler bits since we don't use it
- sed -i -e '/extensiontask/d' -e '/ExtensionTask/,/end/d' -e '/GemPackageTask/,/end/d' Rakefile || die
-
- # replace ulimit -n output as it does not work with Ruby 1.9
- sed -i -e 's:`ulimit -n`:"'`ulimit -n`'":' test/tc_parser.rb || die
-
- # Avoid test failing due to different semantics in libxml 2.8.
- # https://github.com/xml4r/libxml-ruby/issues/43
- sed -i -e '/test_invalid_encoding/,/^ end/ s:^:#:' test/tc_reader.rb || die
-
- # Ignore two test failures on ruby18 for now given that older
- # versions no longer compile.
- sed -i -e '/test_schema_type/,/end/ s:^:#:' \
- -e '/test_schema_element/,/end/ s:^:#:' test/tc_schema.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext/libxml extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -C ext/libxml
- cp ext/libxml/libxml_ruby.so lib/ || die
-}
-
-each_ruby_test() {
- # The test suite needs to load its files in alphabetical order but
- # this is not guaranteed. See bug 370501.
- ${RUBY} -Ilib -r ./test/test_helper.rb test/test_suite.rb || die
-}