summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-25 12:49:52 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-25 12:49:52 +0000
commit801f446b552dedbf9a49d44b721b53b009490f8a (patch)
tree2646d800bfb876181a1c87b4e4e9a1dd210624ef /dev-ruby/libxml/libxml-2.1.1.ebuild
parentTaking maintainership whilst dagger is away. (diff)
downloadgentoo-2-801f446b552dedbf9a49d44b721b53b009490f8a.tar.gz
gentoo-2-801f446b552dedbf9a49d44b721b53b009490f8a.tar.bz2
gentoo-2-801f446b552dedbf9a49d44b721b53b009490f8a.zip
Remove old versions.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/libxml/libxml-2.1.1.ebuild')
-rw-r--r--dev-ruby/libxml/libxml-2.1.1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-ruby/libxml/libxml-2.1.1.ebuild b/dev-ruby/libxml/libxml-2.1.1.ebuild
deleted file mode 100644
index 833a91d89df0..000000000000
--- a/dev-ruby/libxml/libxml-2.1.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.1.1.ebuild,v 1.3 2011/08/15 16:03:02 graaff Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ree18 ruby19"
-
-RUBY_FAKEGEM_NAME="libxml-ruby"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
-HOMEPAGE="http://libxml.rubyforge.org"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND="${RDEPEND} dev-libs/libxml2"
-DEPEND="${DEPEND} dev-libs/libxml2"
-
-ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
-
-all_ruby_prepare() {
- # Remove grancher tasks only needed for publishing the website
- sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
-
- # We don't have the hanna template available.
- sed -i -e 's/hanna/rake/' Rakefile || die
-
- # Remove rake-compiler bits since we don't use it
- sed -i -e '/extensiontask/d' -e '/ExtensionTask/,/end/d' -e '/GemPackageTask/,/end/d' Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext/libxml extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -C ext/libxml
- cp ext/libxml/libxml_ruby.so lib/ || die
-}
-
-each_ruby_test() {
- # The test suite needs to load its files in alphabetical order but
- # this is not guaranteed. See bug 370501.
- ${RUBY} -Ilib -r test/test_helper.rb test/test_suite.rb || die
-}