summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-09-01 12:35:04 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-09-01 12:35:04 +0000
commitb75666c08e97ddb7c5e6e4804367cf09fea6185e (patch)
tree7f6d7c74c037007e946dae21df258be1a559629c /dev-ruby/kramdown
parentMarked ~ppc-aix, bug #432288 (diff)
downloadgentoo-2-b75666c08e97ddb7c5e6e4804367cf09fea6185e.tar.gz
gentoo-2-b75666c08e97ddb7c5e6e4804367cf09fea6185e.tar.bz2
gentoo-2-b75666c08e97ddb7c5e6e4804367cf09fea6185e.zip
Version bump; make sure latex dependencies are also added during test with the flag enabled; use the rdoc recipe for documentation building.
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/kramdown')
-rw-r--r--dev-ruby/kramdown/ChangeLog10
-rw-r--r--dev-ruby/kramdown/kramdown-0.13.8.ebuild (renamed from dev-ruby/kramdown/kramdown-0.13.7.ebuild)18
2 files changed, 16 insertions, 12 deletions
diff --git a/dev-ruby/kramdown/ChangeLog b/dev-ruby/kramdown/ChangeLog
index 551c5b103ac4..4020abdfed09 100644
--- a/dev-ruby/kramdown/ChangeLog
+++ b/dev-ruby/kramdown/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/kramdown
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/ChangeLog,v 1.15 2012/08/25 06:12:44 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/ChangeLog,v 1.16 2012/09/01 12:35:04 flameeyes Exp $
+
+*kramdown-0.13.8 (01 Sep 2012)
+
+ 01 Sep 2012; Diego E. Pettenò <flameeyes@gentoo.org> +kramdown-0.13.8.ebuild,
+ -kramdown-0.13.7.ebuild:
+ Version bump; make sure latex dependencies are also added during test with the
+ flag enabled; use the rdoc recipe for documentation building.
25 Aug 2012; Hans de Graaff <graaff@gentoo.org> -kramdown-0.13.3.ebuild,
-kramdown-0.13.4.ebuild, -kramdown-0.13.5.ebuild, -kramdown-0.13.5-r1.ebuild,
@@ -75,4 +82,3 @@
+metadata.xml:
Initial import. This is a mandatory dependency of app-text/webgen, bug
341067.
-
diff --git a/dev-ruby/kramdown/kramdown-0.13.7.ebuild b/dev-ruby/kramdown/kramdown-0.13.8.ebuild
index 70a95d68fb27..1a221ab38f01 100644
--- a/dev-ruby/kramdown/kramdown-0.13.7.ebuild
+++ b/dev-ruby/kramdown/kramdown-0.13.8.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/kramdown-0.13.7.ebuild,v 1.1 2012/06/04 00:49:02 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/kramdown-0.13.8.ebuild,v 1.1 2012/09/01 12:35:04 flameeyes Exp $
EAPI=4
USE_RUBY="ruby18 ruby19 ree18 jruby"
-RAKE_FAKEGEM_DOCDIR="htmldoc/rdoc"
-RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS ChangeLog CONTRIBUTERS"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOC_SOURCES="lib README.md"
RUBY_FAKEGEM_EXTRAINSTALL="data"
@@ -21,7 +23,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="latex"
-RDEPEND+="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND+=" ${LATEX_DEPS}"
+DEPEND+=" test? ( ${LATEX_DEPS} )"
ruby_add_bdepend "doc? ( dev-ruby/rdoc )
test? ( >=dev-ruby/coderay-1.0.0 )"
@@ -35,12 +39,6 @@ all_ruby_prepare() {
fi
}
-all_ruby_compile() {
- if use doc; then
- rdoc-2 -o htmldoc/rdoc --main README --title kramdown lib README || die "Unable to generate documentation"
- fi
-}
-
all_ruby_install() {
all_fakegem_install