summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-26 11:48:40 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-26 11:48:40 +0000
commitc22d70ab55bd76d9b9318e0395e19e23b8b9ead7 (patch)
treed4fbb94f8ccc75e90e6b260c2e441bfd0b6bf8b9 /dev-ruby/json
parentVersion bump. (diff)
downloadgentoo-2-c22d70ab55bd76d9b9318e0395e19e23b8b9ead7.tar.gz
gentoo-2-c22d70ab55bd76d9b9318e0395e19e23b8b9ead7.tar.bz2
gentoo-2-c22d70ab55bd76d9b9318e0395e19e23b8b9ead7.zip
Revision bump to make 1.4.3-r1 the new stable candidate with support for ruby18 and jruby.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/ChangeLog9
-rw-r--r--dev-ruby/json/json-1.4.3-r1.ebuild4
-rw-r--r--dev-ruby/json/json-1.4.3-r2.ebuild65
3 files changed, 75 insertions, 3 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index 1958dc5cf729..75dccbc501c7 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.33 2010/06/12 10:43:28 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.34 2010/06/26 11:48:40 graaff Exp $
+
+*json-1.4.3-r2 (26 Jun 2010)
+
+ 26 Jun 2010; Hans de Graaff <graaff@gentoo.org> json-1.4.3-r1.ebuild,
+ +json-1.4.3-r2.ebuild:
+ Revision bump to make 1.4.3-r1 the new stable candidate with support for
+ ruby18 and jruby.
12 Jun 2010; Hans de Graaff <graaff@gentoo.org> json-1.4.3-r1.ebuild:
Fix static modname and add x64-macos keyword, fixing bug 323371. Thanks to
diff --git a/dev-ruby/json/json-1.4.3-r1.ebuild b/dev-ruby/json/json-1.4.3-r1.ebuild
index 4388547f641a..77b787ca1a69 100644
--- a/dev-ruby/json/json-1.4.3-r1.ebuild
+++ b/dev-ruby/json/json-1.4.3-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.4.3-r1.ebuild,v 1.2 2010/06/12 10:43:28 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.4.3-r1.ebuild,v 1.3 2010/06/26 11:48:40 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 jruby"
RUBY_FAKEGEM_TASK_DOC="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"
diff --git a/dev-ruby/json/json-1.4.3-r2.ebuild b/dev-ruby/json/json-1.4.3-r2.ebuild
new file mode 100644
index 000000000000..afe604c336bd
--- /dev/null
+++ b/dev-ruby/json/json-1.4.3-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.4.3-r2.ebuild,v 1.1 2010/06/26 11:48:40 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A JSON implementation as a Ruby extension."
+HOMEPAGE="http://json.rubyforge.org/"
+LICENSE="|| ( Ruby GPL-2 )"
+SRC_URI="mirror://rubygems/${P}.gem"
+
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris ~x64-macos"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND}"
+DEPEND="${DEPEND}
+ dev-util/ragel"
+
+ruby_add_bdepend "dev-ruby/rake
+ test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # Avoid building the extension twice!
+ sed -i \
+ -e 's| => :compile_ext||' \
+ -e 's| => :clean||' \
+ Rakefile || die "rakefile fix failed"
+}
+
+each_ruby_compile() {
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ${RUBY} -S rake compile_ext || die "extension compile failed"
+ fi
+}
+
+each_ruby_test() {
+ # We have to set RUBYLIB because otherwise the tests will run
+ # against the sytem-installed json; at the same time, we cannot
+ # use the -I parameter because rake won't let it pass to the
+ # testrb call that is executed down the road.
+
+ RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
+ ${RUBY} -S rake test_pure || die "pure ruby tests failed"
+
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext" \
+ ${RUBY} -Ilib:ext -S rake test_ext || die " ruby extension tests failed"
+ fi
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
+ ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
+ fi
+}