summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-09-12 17:29:52 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-09-12 17:29:52 +0000
commitca4c7e831caf9aafba51b2d979d1b8d64b8c78ca (patch)
treef5bb07c72df7bfbb396d565382d2d3bc7d062d9b /dev-ruby/httpclient
parentVersion bump (diff)
downloadgentoo-2-ca4c7e831caf9aafba51b2d979d1b8d64b8c78ca.tar.gz
gentoo-2-ca4c7e831caf9aafba51b2d979d1b8d64b8c78ca.tar.bz2
gentoo-2-ca4c7e831caf9aafba51b2d979d1b8d64b8c78ca.zip
Cleanup old.
(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/httpclient')
-rw-r--r--dev-ruby/httpclient/ChangeLog5
-rw-r--r--dev-ruby/httpclient/httpclient-2.2.2.ebuild65
-rw-r--r--dev-ruby/httpclient/httpclient-2.3.3.ebuild53
3 files changed, 4 insertions, 119 deletions
diff --git a/dev-ruby/httpclient/ChangeLog b/dev-ruby/httpclient/ChangeLog
index 871e5e3fa8b1..5f16fe4f0f26 100644
--- a/dev-ruby/httpclient/ChangeLog
+++ b/dev-ruby/httpclient/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/httpclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.49 2013/09/12 17:20:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.50 2013/09/12 17:29:52 mrueg Exp $
+
+ 12 Sep 2013; Manuel Rüger <mrueg@gentoo.org> -httpclient-2.2.2.ebuild:
+ Cleanup old.
12 Sep 2013; Agostino Sarubbo <ago@gentoo.org> httpclient-2.2.5.ebuild:
Stable for ppc, wrt bug #483702
diff --git a/dev-ruby/httpclient/httpclient-2.2.2.ebuild b/dev-ruby/httpclient/httpclient-2.2.2.ebuild
deleted file mode 100644
index fd9c31ab3880..000000000000
--- a/dev-ruby/httpclient/httpclient-2.2.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.2.2.ebuild,v 1.10 2012/05/21 10:17:12 phajdan.jr Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="-Ilib test"
-RUBY_FAKEGEM_TASK_DOC="doc"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="README.txt"
-
-inherit ruby-fakegem
-
-DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
-HOMEPAGE="https://github.com/nahi/httpclient"
-SRC_URI="https://github.com/nahi/httpclient/tarball/v${PV} -> ${P}.tgz"
-RUBY_S="nahi-httpclient-*"
-
-LICENSE="Ruby"
-SLOT="0"
-
-KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="${RDEPEND}
- !dev-ruby/http-access2"
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
-
-all_ruby_prepare () {
- rm Gemfile || die
- sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
-
- # Comment out harmless test failures with ruby 1.8, bug 411191
- sed -i -e '228,268 s:^:#:' test/test_http-access2.rb || die
-
- # Comment out test requiring network access that makes assumptions
- # about the environment, bug 395155
- sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
-}
-
-each_ruby_prepare() {
- # Don't run two tests that are known to fail with jruby. This is a
- # bug in jruby that won't be fixed until jruby 1.7.
- # https://github.com/nahi/httpclient/issues/61
- case ${RUBY} in
- *jruby)
- sed -i -e '/test_get_gzipped_content/,/end/s:^:#:' \
- -e '/test_socket_local/,/^ end/s:^:#:' \
- test/test_httpclient.rb
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib -S testrb test/test_*.rb || die
-}
diff --git a/dev-ruby/httpclient/httpclient-2.3.3.ebuild b/dev-ruby/httpclient/httpclient-2.3.3.ebuild
deleted file mode 100644
index 93d02e85fb2b..000000000000
--- a/dev-ruby/httpclient/httpclient-2.3.3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.3.3.ebuild,v 1.1 2013/05/04 15:59:52 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="-Ilib test"
-RUBY_FAKEGEM_TASK_DOC="doc"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="README.txt"
-
-inherit ruby-fakegem
-
-DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
-HOMEPAGE="https://github.com/nahi/httpclient"
-SRC_URI="https://github.com/nahi/httpclient/tarball/v${PV} -> ${P}.tgz"
-RUBY_S="nahi-httpclient-*"
-
-LICENSE="Ruby"
-SLOT="0"
-
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="${RDEPEND}
- !dev-ruby/http-access2"
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
-
-all_ruby_prepare () {
- rm Gemfile || die
- sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
-
- # Remove mandatory CI reports since we don't need this for testing.
- sed -i -e '/reporter/s:^:#:' Rakefile || die
-
- # Remove mandatory simplecov dependency
- sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' test/helper.rb || die
-
- # Comment out test requiring network access that makes assumptions
- # about the environment, bug 395155
- sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib -S testrb test/test_*.rb || die
-}