summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-31 11:33:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-31 11:33:35 +0000
commitd9adfd2ea1f2d05f5a165d0864e2a2f157b6764c (patch)
tree1559bc778295871a6c78ebc00428e080c4f8d44f /dev-ruby/httparty
parentAdd prefix keywords, change EAPI to 3. (diff)
downloadgentoo-2-d9adfd2ea1f2d05f5a165d0864e2a2f157b6764c.tar.gz
gentoo-2-d9adfd2ea1f2d05f5a165d0864e2a2f157b6764c.tar.bz2
gentoo-2-d9adfd2ea1f2d05f5a165d0864e2a2f157b6764c.zip
Version bump, port to fakegem ppc and x86 need to re-keyword crack for this to work.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/ChangeLog9
-rw-r--r--dev-ruby/httparty/httparty-0.5.1.ebuild60
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-ruby/httparty/ChangeLog b/dev-ruby/httparty/ChangeLog
index a5ffef6fc08d..76c5ab6a99d8 100644
--- a/dev-ruby/httparty/ChangeLog
+++ b/dev-ruby/httparty/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/httparty
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.10 2010/01/10 08:58:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.11 2010/01/31 11:33:35 flameeyes Exp $
+
+*httparty-0.5.1 (31 Jan 2010)
+
+ 31 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +httparty-0.5.1.ebuild:
+ Version bump, port to fakegem ppc and x86 need to re-keyword crack for
+ this to work.
10 Jan 2010; Hans de Graaff <graaff@gentoo.org> -httparty-0.4.3.ebuild,
-httparty-0.4.4.ebuild:
diff --git a/dev-ruby/httparty/httparty-0.5.1.ebuild b/dev-ruby/httparty/httparty-0.5.1.ebuild
new file mode 100644
index 000000000000..739491dfe725
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.5.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/httparty-0.5.1.ebuild,v 1.1 2010/01/31 11:33:35 flameeyes Exp $
+
+EAPI=2
+
+# ruby19 → testsuite fails (might be crack's bug)
+# jruby → testsuite fails (seems like a testuite bug)
+USE_RUBY="ruby18"
+
+# We have a custom test function, but don't null this out so that the
+# deps are still added
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy."
+HOMEPAGE="http://httparty.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Code should most likely be patched, but for now…
+ruby_add_rdepend '~dev-ruby/crack-0.1.5'
+
+ruby_add_bdepend 'dev-ruby/rspec dev-ruby/fakeweb'
+
+USE_RUBY=ruby18 \
+ ruby_add_bdepend 'ruby_targets_ruby18 test' 'dev-util/cucumber dev-ruby/activesupport:2.3'
+
+all_ruby_prepare() {
+ # as often, Rakefile depends on Jeweler's presence
+ sed -i \
+ -e '/check_dependencies/s:^:#:' \
+ Rakefile || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby18)
+ # Cucumber-based tests only work on Ruby 1.8, as of today, so we only call them
+ ${RUBY} -S rake spec features || die "cucumber tests failed"
+ ;;
+ *)
+ ${RUBY} -S rake spec || die "cucumber tests failed"
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}