summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-05-13 05:33:38 +0000
committerHans de Graaff <graaff@gentoo.org>2012-05-13 05:33:38 +0000
commit44fbf42df5331436d44d0be51b1d9817a4f3c1d7 (patch)
treea8ed163ecd979b6e8b8ebb77dbee0b1d4480b3b0 /dev-ruby/httparty
parentVersion bump. Removee old (diff)
downloadgentoo-2-44fbf42df5331436d44d0be51b1d9817a4f3c1d7.tar.gz
gentoo-2-44fbf42df5331436d44d0be51b1d9817a4f3c1d7.tar.bz2
gentoo-2-44fbf42df5331436d44d0be51b1d9817a4f3c1d7.zip
Version bump. Drop ppc due to new multi_xml dependency, bug 415691.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/ChangeLog9
-rw-r--r--dev-ruby/httparty/httparty-0.8.3.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/dev-ruby/httparty/ChangeLog b/dev-ruby/httparty/ChangeLog
index 458bc8374ae0..1aeaaf717ee1 100644
--- a/dev-ruby/httparty/ChangeLog
+++ b/dev-ruby/httparty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/httparty
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.20 2010/10/09 09:25:17 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.21 2012/05/13 05:33:38 graaff Exp $
+
+*httparty-0.8.3 (13 May 2012)
+
+ 13 May 2012; Hans de Graaff <graaff@gentoo.org> +httparty-0.8.3.ebuild:
+ Version bump. Drop ppc due to new multi_xml dependency, bug 415691.
09 Oct 2010; Hans de Graaff <graaff@gentoo.org> httparty-0.6.1.ebuild:
Add missing dependency on mongrel. Thanks to Nathan Phillip Brink for
diff --git a/dev-ruby/httparty/httparty-0.8.3.ebuild b/dev-ruby/httparty/httparty-0.8.3.ebuild
new file mode 100644
index 000000000000..43708dcb8ecf
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.8.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/httparty-0.8.3.ebuild,v 1.1 2012/05/13 05:33:38 graaff Exp $
+
+EAPI=2
+
+# jruby → testsuite fails (seems like a testuite bug)
+USE_RUBY="ruby18 ruby19 ree18"
+
+# We have a custom test function, but don't null this out so that the
+# deps are still added
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy."
+HOMEPAGE="http://httparty.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend '=dev-ruby/multi_json-1* dev-ruby/multi_xml'
+
+ruby_add_bdepend 'dev-ruby/rspec:0 dev-ruby/fakeweb'
+
+USE_RUBY=ruby18 \
+ ruby_add_bdepend 'test? ( dev-util/cucumber www-servers/mongrel )'
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby18)
+ # Cucumber-based tests only work on Ruby 1.8, as of today, so we only call them
+ ${RUBY} -S rake spec features || die "cucumber tests failed"
+ ;;
+ *)
+ ${RUBY} -S rake spec || die "cucumber tests failed"
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}