summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-03-29 07:07:12 +0000
committerHans de Graaff <graaff@gentoo.org>2015-03-29 07:07:12 +0000
commit3356718b953e5e9d3cb9da852cc870a5152de65b (patch)
tree6b4f1ea3109a60a27685d960915cbd64daabe8bc /dev-ruby/http-cookie
parentVersion bump for security bug 544326. (diff)
downloadgentoo-2-3356718b953e5e9d3cb9da852cc870a5152de65b.tar.gz
gentoo-2-3356718b953e5e9d3cb9da852cc870a5152de65b.tar.bz2
gentoo-2-3356718b953e5e9d3cb9da852cc870a5152de65b.zip
Create stable candidate.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/http-cookie')
-rw-r--r--dev-ruby/http-cookie/ChangeLog8
-rw-r--r--dev-ruby/http-cookie/http-cookie-1.0.2-r1.ebuild30
-rw-r--r--dev-ruby/http-cookie/http-cookie-1.0.2.ebuild4
3 files changed, 39 insertions, 3 deletions
diff --git a/dev-ruby/http-cookie/ChangeLog b/dev-ruby/http-cookie/ChangeLog
index 2f27fea28300..574c241f7fea 100644
--- a/dev-ruby/http-cookie/ChangeLog
+++ b/dev-ruby/http-cookie/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/http-cookie
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http-cookie/ChangeLog,v 1.5 2015/02/10 09:27:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http-cookie/ChangeLog,v 1.6 2015/03/29 07:07:12 graaff Exp $
+
+*http-cookie-1.0.2-r1 (29 Mar 2015)
+
+ 29 Mar 2015; Hans de Graaff <graaff@gentoo.org> http-cookie-1.0.2.ebuild,
+ +http-cookie-1.0.2-r1.ebuild:
+ Create stable candidate.
10 Feb 2015; Agostino Sarubbo <ago@gentoo.org> http-cookie-1.0.2.ebuild:
Add ~ppc, wrt bug #522056
diff --git a/dev-ruby/http-cookie/http-cookie-1.0.2-r1.ebuild b/dev-ruby/http-cookie/http-cookie-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..c07c8a734c3d
--- /dev/null
+++ b/dev-ruby/http-cookie/http-cookie-1.0.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http-cookie/http-cookie-1.0.2-r1.ebuild,v 1.1 2015/03/29 07:07:12 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library to handle HTTP cookies"
+HOMEPAGE="https://github.com/sparklemotion/http-cookie"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/domain_name-0.5:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/d" -e "/bundler/d" Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_http_cookie.rb || die
+ ${RUBY} -Ilib test/test_http_cookie_jar.rb || die
+}
diff --git a/dev-ruby/http-cookie/http-cookie-1.0.2.ebuild b/dev-ruby/http-cookie/http-cookie-1.0.2.ebuild
index 4b6f7fc2f176..c096347ab038 100644
--- a/dev-ruby/http-cookie/http-cookie-1.0.2.ebuild
+++ b/dev-ruby/http-cookie/http-cookie-1.0.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http-cookie/http-cookie-1.0.2.ebuild,v 1.5 2015/02/10 09:27:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http-cookie/http-cookie-1.0.2.ebuild,v 1.6 2015/03/29 07:07:12 graaff Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"